* A Fix for the Update Loop Error in Diablo 1

UPDATE: A script has been written that will do everything below with a single click.

If you’d prefer that route, see “Patch #1here.


Hey all,

Before I start, let me put out a disclaimer: The fix involves modifying the system’s Registry. Therefore, do this fix only if you’re comfortable poking around the registry, or if you are good at following directions!

The fix modifies a part of the registry that’s fairly straight forward to locate and it won’t damage your overall system if you make a mistake. However, if you modify any other parts of the Registry, even by accident, you could cause damage to the system’s functionality. In other words, apply this fix at your own risk.

  • Why the update looping error happens.

When Diablo 1 is installed from Battlenet, there are two possible Battlenet gateway configurations a player can get: Either a single “Global” gateway, or the four legacy gateways (East, West, Europe, Asia).

The Global gateway is the correct one. This is evidenced by the fact that in all the other official versions of the classical games, 1) the Global gateway is present, and 2) the legacy gateways are absent.

In other words, only the Global gateway is available in Bliz’s WC2, in GoG’s WC2 and in GoG’s D1. (The legacy gateways aren’t available in any of those.) Based off its ubiquitous use, that implies that the Global gateway is what Bliz intended to be present in their version of Diablo 1 as well.

Side note: Some refer to the Global gateway as “GoG’s gateway”. However, it is indeed Bliz’s gateway and it is hosted on Battlenet. GoG simply coded it into their versions of D1 and WC2. So, whichever version is played, Bliz’s or GoG’s, it all connects to the same place: Bliz’s Battlenet.

  • The fix

Now to it. Those experiencing the update looping error will be modifying a single subkey in their system’s Registry to allow the Global gateway to appear, and to remove the four legacy gateways (since they don’t work anyway).

If you haven’t done so yet, open the game and go to the “Multi Player” screen (where the gateways are displayed). Nothing more is needed there so you can close out Diablo 1.

The screenshots below can be clicked to enlarge.

**Follow the steps below carefully.**

  1. Open the Registry Editor. In Win10, you can type “reg” in the search bar:

  1. Copy and paste the path below into the editor’s top bar and then press Enter:
    Computer\HKEY_CURRENT_USER\SOFTWARE\Battle.net\D1\Configuration
    (That will jump you right to the proper location without having to manually navigate.)

  1. In the right pane, right-click the words Battle.net gateways and select Modify:

  1. In the small window that opens, delete everything in the “Value data” box. Be sure to delete everything, including spaces:

  1. In the “Value data” box, paste the lines below EXACTLY as they appear here, all in one paste, then click “OK”:
2000
01
connect-forever.classic.blizzard.com
8
Global

  1. Confirm the text to the right reads:
    2000 01 connect-forever.classic.blizzard.com 8 Global

  1. Exit the Registry Editor by clicking the “x” in the upper right corner.
  2. Launch D1 and confirm that “Global” displays as the gateway:

If so, the update looping error should be fixed and you’re good to go!

[Thanks to LionHeart and Xcluusive for contributing to this.]

1 Like

microsoft. com/software-download/windows11
Fresh Install of windows 11.
Fresh install of blizzards Battle.net launcher
Just bought Diablo 1 classic on the Battle.net launcher.

Installed Diablo 1 Hellfire
Main Menu > Multiplayer Option Missing.
Exited Game.

Installed Diablo 1 Classic. ( V 1.0.9.2 ) latest
Main Menu > Multiplayer > Battlenet > Shows the 4 Legacy Gateways.

(Note)
Maybe the Legacy Gateways Defaulted, because i installed & launched Hellfire
Version first, even though multiplayer is not even an option on the main menu.

i can confirm this Registry Edit solution works for windows 11 as well
Deleting Legacy Gateways, and adding the Global Gateway.

As much as I appreciate the solution, this shouldn’t even be an issue.
Considering the Game version is 1.0.9.2 ( Version Created in 2024 )
Hope this issue gets fixed soon !

Hellfire doesn’t have multiplayer by design, that’s expected.

As far as those around here have able to tell, if GoG’s version of D1 has been installed first, the correct gateway configuration will appear in Bliz’s version. That’s due to GoG’s version creating the correct configuration, and then Bliz’s version uses it.

However, if Bliz’s version was installed first, then it creates the wrong configuration.

Glad to hear the fix works on Win11!

DevilutionX can be used to play Hellfire in multiplayer if that is prefered.