To those who are having the D1 update loop problem:

[UPDATE Feb-4]
My original post here was more about collecting info on the update looping error. And now, a fix has been found. See here for detailed instructions on how to fix it:


[Deleted OP as it’s not necessary anymore. See update above.]

1 Like

As you know, from last night’s test, I am no longer experiencing the update loop problem.

My current registry is showing:

2000 01 connect-forever.classic.blizzard.com 8 Global

I don’t know what it was before I added the Custom Port Forwarding Service to my modem gateway.

Thanks!

Was that on Bliz’s version (from the launcher)?

I’m not sure what you’re asking.

If you’re referring to last night’s test, obviously it was Blizzard’s version. And yes, I ran it from the Battle․net App. Not the Diablo.exe file directly.

If you’re referring to the Registry entry, I would think GOG’s entry is in another location. (I’m not sure about that, as I’m not that computer tech-savvy).

Based on your instructions, this is what my D1 Configuration Registry entry looks like:

https://i.imgur.com/DSlTSdD.jpg

Embedding the preview for you…

1 Like

Mine is the top one with 1000 02 in it. I copied and paste both top and bottom entries into my registry key. I am still in the boot loop.

Only the “Global” gateway can be used. The other four won’t work.

yeah, this solved the update loop problem. Now i am at the battle.net global server. But i can’t create or join a game, because it returns a error about the port 6112, and says i can only chat. How can i open this 6112 port ?

For that, you’ll need to make a few settings in your router. See here:

You can forward ports to only one computer (on a standard home network setup), so make sure to forward the ports to the IP of your gaming computer.

Just as a side note, this isn’t a bug or anything like that. Every official version of D1 requires this due to how old the game is. Where Bliz messed up is…

They didn’t tell anyone about it.

I can’t do the steps in this link you sent. And the port foward. com is a lot complex for me to try. I saw in another forum here an user sent a good step-by-step on how to open these 6112-6119 ports, but i can’t find it anymore. I think it was in the first forum about the directdraw error, but i just can’t find it again. It was more easy to do. Please help if you can get this steps again.

The tricky part is just figuring out where in your router settings the Port Forwarding is. Because there’s so many different makes and models of routers, there are many different places those settings could be.

You can try searching for your make and model with “port fowarding” in the search. That may bring up something that is specific to your router.

This new registry key did NOT fix my boot loop issue. I have it setup correctly and it is still in the boot loop.

What do I do now? I am on Win 11 Pro not home. Also when I copy that registry entry and go to save it, it tells me that spaces are not allowed in it. But it saves anyways. I have reboot my pc. Something ain’t right here.

Did you confirm that the Global gateway is now the selected one (lower left corner) in Diablo right before you connect to battle.net? If it still doesn’t work you can try via DevilutionX instead.

I understand your frustration with the issue, but it seems a bit counterintuitive to reject free community fixes simply because you’ve already paid for a faulty product. Considering you need the game for the fix to be relevant, it wouldn’t be a wasted purchase either. We’re all community members here, just trying to help, so it isn’t really fair to vent your anger at us. Besides, it likely won’t be seen by Blizzard staff.

jarablue,

Seeing no one knows what you did in your Registry, please go though the steps of this tutorial exactly. Based off reports, it has worked in eliminating the update looping error for those who had it in Bliz’s version, including me.

If, by chance, it doesn’t work, it would suggest that there’s something unique to your system environment causing your problems. I suggest that because, per our previous convos, the port forwarding also isn’t working for you.

Also, you’re not helping people understand your issue when you consistently refer to your problem as “boot loop error”. That means something totally different than “update loop error”.

In the end, if you can’t get the gateways to work then refund D1. If you want to play D1 online, GoG’s version of D1 works fine.

Lastly, frustration is understandable. However, it’s not license to break the forum rules. I’d recommend you edit the profanity, including the masked profanity, out of your last post. You could lose your posting priviledges which would make it even more difficult to find help.

oh god i can’t believe blizzard is selling this game with this tricky error, so hard to solve. Man i tried to open this 6112 and 6119 port by the port forwardnig in the router, direct with the support of my internet provider, and it’s still not oppening to play in the battle.net server. Why blizzard don’t solve this before launching the game again ? oh my !!! I have yet solved the update loop by the solutions of the global server that you guys placed here, but this 6112 port error, its still blocking me. please help

Did you forward 6112 through 6119? Not just 6112 and 6119?

And, was it to the IP of the computer you are playing on? Port forwarding will only work on a single IP, meaning a single device, at a time. If you change to a different device on your network, say desktop to a laptop, you’d have to change the IP in the port fowarding settings also.

The port issue isn’t something they likely ever planned to solve. It just a requirement for every official version of the game due to how old it is. Even GoG’s modernized version requires it.

The update looping, however, that’s a bug. Bliz is aware of it so hopefully they will fix it.

Still not working. Registry is correct. Ports are forwarded correct. Still not working. Please fix. Thanks.

Make sure no other firewalls are active. Lot’s of antimalware apps come with firewalls, Windows does, and lots of other 3rd party places that firewalls can come from.

That said, Bliz cannot fix your system.