* A Fix for the Update Loop Error in Diablo 1

Hey folks,

I posted a detailed fix to the Diablo 1 update looping error over in the Legacy Game Tech Support forum:

1 Like

Worked like a charm. Thanks!

While having multiple issues running the game, I uninstalled and reinstalled thru the Battlenet client. I now have no Registry entry for Diablo 1…
Still having blank screen on menu, when menu does show I get blank screen upon making any selection, sometimes on mouse movement the screen will flicker with odd color of the outlines of the UI. I was excited to try this update loop fix after reinstalling but the problems are worse now.

Ah, yes. There’s a reason for that.

In order for the registry key (and its subkeys) to appear, you have to make it to the “Multi Player” screen (where the gateways are displayed) at least once.

So, if you can manage to fight your way there, the registry will update and you’ll see all the stuff pictured in the fix guide.

I’ll add that info to my guide.

Unfortunately, this fix won’t affect the crashes or black screens.

Yeah, that’s a whole other issue. Some people have it bad while others not as bad. I, for example, don’t have much trouble on my desktop, but my laptop can barely run the game at all.

The black screen issue can be solved by either using a DirectDraw wrapper or DevilutionX to run the game.

Do you have a specific ddwrapper and a place to get it that you recommend?

1 Like

I would suggest cnc-ddraw, it’s not to fancy but robust

1 Like