WoW won't update

Hi,

I’ve been getting this error -Please try again after logging on as an administrator, when I try to update. I am the admin on my computer but it’s still not updating. I’ve tried their suggestion but it’s not working. Has anyone else had this issue?

28 Likes

Having the same issue today. I even went as far as reinstalling the Battlenet app but no luck getting rid of this error. glad its not just me cause I’m pretty sure I didn’t do anything to trigger this.

Mac OS 12.0.1

4 Likes

You’re not the only one who has this problem. It was working fine yesterday and going to log on today, I’m like what the heck lol

5 Likes

Yup, had no problems yesterday, only this morning.

1 Like

Yeah. I restarted my computer multiple times, deleted the tools folder, ran the games as admin, yet still nothing is working.

2 Likes

Yeah I did the same thing, I reinstalled but no luck Mac OS 15.1

1 Like

Same here, won’t update Shadowlands due to Admin error (I am admin)…tried BN reinstall, created new Admin user on OS, repair wont even work. Come on Blizz!

Also, same problem with beta battlenet, so version of BN doesn’t matter. WoW app does launch directly with no problems w/o battlenet though, so is playable

3 Likes

Same problem for me

Mac OS 12.0.1 iMac M1

2 Likes

Same, very frustrating knowing name reservations are tonight

1 Like

I don’t have anything new to add other than I cannot log in either, but was able to do so just fine last night.

MacOS 10.15.7 (Late 2015 iMac)

1 Like

BLZBNTAGT0000841 error? Same. Tried steps in troubleshooting article (which does not address Macs specifically) : https://us.battle.net/support/en/article/30271
Still won’t update. I adapted these - adding my Admin account specifically to permissions for Battlenet, world of warcraft folder and Wow application. Still no update which means no login, which means no playing today for me. :cry:

I too have been having the same issue. The Battle.net application response when I press the Update button in the Battle.net app is “Please try again after logging on as an administrator.” This is for both retail and classic versions.

After some research and trouble shooting I found that the permissions on the /Applications/World\ of\ Warcraft/Data directory was set to 666, basically my admin account could Read and Write but not execute.
I tried launching the game manually but I received a modal window with an error of “Cannot start WoW. ClientHandler: initialization error: failed to create storage component.” I did a quick Google search and found this article https://us.battle.net/support/en/article/13934
Followed those recommendations to no avail.

I am able to manually launch the game now after opening up a terminal and running the following:
“sudo chmod -R 777 /Applications/World\ of\ Warcraft/Data”

Looks like a recent patch to the Battle.net application migrated some bad file permissions.

Mid 2017 iMac running Mac OS 11.6

10 Likes

Same problem here, 2019 imac, newest OS.

You can directly launch wow from your applications folder still though if people are interested, but yes an annoying bug.

1 Like

If launching the game directly the authenticator never works for me, maybe that is just a me problem I don’t know. But always works with site and battle.net login.

2 Likes

I couldn’t get my authenticator to register a login attempt either. I was so excited to be able to login, only to fail at the last second. So much for launching the game without the battlenet client.

1 Like

The problem appears to be fixed. My battle.net launcher updated the game with no issues and all I did was relaunch it. Hopefully it works now for the rest of you!

No such luck here

I’m having the same issue. I’ve reinstalled a bunch of times, finally came here to see if there were others having this same issue. Hopefully this gets fixed.

Same issue… guess I will play FFXIV, they know how to not break stuff every other day…

2 Likes

Same issue. Please try again after logging on as an administrator.
MacBook Pro 16 M1 Pro