Wow freezes for 4-5 seconds then resumes to normal

Hi, currently my friend’s computer is having issues running wow without getting complete freezes for 4-5 seconds then it goes back to normal. It’s not a black screen either it only fully crashed the PC once so far in a session that I witnessed of 4-5 hours. I can still alt+tab and checked the CPU % and it was only 65%. When I tried with another GPU it didn’t do any of these freezes so that’s why I doubt it’s RAM or CPU issue there. With the other graphics card it didn’t do any freezing or crashing. I tried with and without addons and no difference, re-installed but the issues are still there. Tried with V-sync on and off no difference still having freezing issues. Tried deleting cache folder and trying, still freezing. Drivers are up to date for the GPU. The temperatures don’t even go above 65c for the GPU at load so I doubt it’s the issue, no overclock on gpu or but cpu is overclocked and stable. I tried Direct X 11, Direct X11 legacy and Direct X12 issue still present.

Runs fine in other games, did 5 hours of cpu and gpu stress test (aida 64, cinderbench, 3d mark and ran fine with no issues but had high temps after 4 hours)

I’m clueless on what I can do to fix the freezing.

Since it works and doesn’t freeze with another graphics card i’m really wondering what is causing this issue. I doubt that’s it’s hardware related but most likely software related. Thanks for trying to help me!

Spec of the PC

CPU: Ryzen R5 1600
GPU: Asus RX 570 expedition 4GB

Ram 2X4GB DDR4 patriot @2400
Mobo: MSI B450 Bazooka V2

Storage: Kingston SSD

Windows 10 64 bit

Running at 1920x1080

Hi Apologian

Have you tried reinstalling the Nvidia using the DDU tool. Clean out all remnants of Nvidia and old Nvidia. Official download is here:

Basically you extract the uninstaller from the download. (it will extract to a folder called DDU) *Then unplug the Ethernet or disable the Wifi to avoid Windows automatic driver installation.

I like to boot the computer into safe mode then run the DDU tool. (This isn’t essential and you will need to confirm you have the windows password before you do so. If you are using a PIN it will ask for the actual password after running safe mode.)

On the tool you select Graphics type then Nvidia. Run the recommended “Clean then restart”.

(If AMD graphics were installed at one time you would want to run the tool again - set it to AMD then clean those remnants out)

Now for the install. Start the driver download. Select Custom Install carry on to the next pane that has the various softwares to install. Uncheck everything except graphics - no Geforce Experience - no 3D Vision drivers. There is a box to check for Clean Install select (check) that box. (Resets the Nvidia control panel and profiles to defaults)

Well since i’m using an AMD GPU in this case the RX 570 I use AMD drivers, I used ddu to remove the previous amd drivers and I installed the new updated drivers and it still causes freezing. Then I used DDU again and then I downloaded a 2018 version of the drivers and it still caused it. I tried both drivers with Direct X 11 and Direct X 12 and still having the issue.

Hey Apologian,

Let’s try disabling all overclocking. Also double check that the powersupply you are using is large enough to run everything. It may also be worth doing a BIOS update and grabbing the Ryzen chipset.

If this persists we should gather some additional information to help pinpoint the problem. Please reply with your DxDiag:

  1. Press Windows Key + R.
  2. Type DxDiag and press Enter.
  3. In the DxDiag window, click Save All Information.
  4. Name the file “dxdiag” and click Save
  5. Paste the DxDiag into a new post, select and highlight everything you just pasted, and hit the (</>) button. That’ll make the information much more readable.

If you have issues pasting here, please use Pastebin and post the link (ex: Pastebin (dot) com/123456).

If you switch to DX11 from DX12 your problem will go away and you will still get just as good performance. I struggled with the same issue for weeks before finding the fix.


Since patch 8.2 I been sufering this same issue,… i tried already literally all crazy things to “fix it” (yes even clear windows reinstall) with 3 options.

  1. Go back to Win7 (U_U nope, i delayed the transsition from w7 to w10 as much i could and i’m not going back now ¬¬)
  2. Like @Iridium said: changing the api from Directx12 to 11 will do the trick althoug not so sure cause in my case Dx11/notLegacy drop the performance drasticly like can’t use ultra settings cause i go from 120fps to 42fps.
  3. Change to other than Kingston SSD : for some reason apparently this SSD have some issue with the maneage of data transfer from the cpu to the gpu I dunno some DX12 feature. (I have the 240G: SA400S37240G will be good if more users with this same issue have this SSD or another brand)
1 Like

Not sure what specs you are running but that seems pretty low. I’m running a GTX 1060 that is several years old.

yeps kinda low U_U
Ryzen7 2700 3.20ghz, 8G x2 hyper 2400, Nv Gf Gtx 1050Ti OC 4g

Sorry, was out for work during the week.

Here’s the DxDiag

pastebin (dot com) /rR22dEdP

The power supply is a 600 watts EVGA 80+ bronze, should be plenty of power for this system.
@ Zenlaka

Hi again Apologian

The only thing showing is a string of AMD Radeon Settings control panel errors. Hard to say if those were there before the DDU uninstall. Try a Selective Startup that may give us some clues.

Follow the instructions on the first portion of this support page carefully. (The other sections are for pinpointing troublesome processes later)

Hi Tratt, thanks for that suggestion but i tried that and still didn’t worked.

Is it possible that since it’s a ryzen first gen the ram could cause the freezing? maybe the speed is too high? I mean it’s set at 2400 but maybe I could try putting it lower.

The Ram is running at stock speed. That should be fine. Let’s clear your error logs see if any new errors pop up that may give us some insight.

Type cmd in the Windows search box. Command Prompt should pop up - right click Command Prompt then select “Run as Administrator”. Once you have it open copy - paste this line at the blinking cursor.

for /f “tokens=*” %1 in (‘wevtutil.exe el’) do wevtutil.exe cl “%1”

Hit Enter and it will run. If it worked you will see a long stream of data run.

I want to take a look at some HWMonitor outputs while the game is running.

Download HWMonitor here:

Free download is along the left side of page - called “Setup - English”

Open it on desktop - go play for a few minutes fight some mobs then tab out. Take a screenshot of the tool. Scroll down on tool to get the rest of the outputs then take another screenshot.

Upload those to Imgur or a similar site. I use

The first thing didn’t worked it said ‘/f’ is not recognized as an internal or external command, operable program or batch file.

Here’s the HWM thing, I did a bg and some questing too for about 30-40 mins

postimg (dot) cc/gallery/ta75tq10/f34b7b3d/

I can’t seem to make that link work - try enclosing the complete link in tilde symbols (key on left side of 1 key) ~~~

should look like this:

postimg (dot) cc/gallery/ta75tq10/f34b7b3d/

postimg (dot) cc/gallery/ta75tq10/

Ahh got it working there. Nothing looks off on those. Let’s have a look at a CPU-Z report next.

Download the free version of the CPU-Z tool here:

(Download Button on left side of page - “Setup - English”)

Run it on desktop. Along the bottom beside Tools button is a dropdown arrow. Click that then select Save Report as .TXT - paste the report.

Here it is, using pastebin since it makes reading easier.

pastebin (dot) com/N7r9DJsr

You mentioned the Ram earlier. Now I see the 2400 Mhz is the XMP timing. Let’s turn XMP off to test things at stock SPD timings.

There is a recent chipset driver available on the MSI support page. Was that installed?

I have a similar problem (sorry if its not same as OP). It has only happened lately (past 2-3 weeks max). I’ll be on WoW on main screen and youtube on second screen then once every 5-8 hours (it is very sporadic) my game will freeze but I can still interact with windows and the audio will suttter for maybe 5-10 seconds then it unfreezes like nothing happen. I’ve had no issues with my PC before this so I used DDU and tried drivers 430.64 and 431.60 (gtx 1070) both using safe boot. After using 431.60 it seems its made it more sporadic (less occuring but still there). My event logs show an error EXTRA_MACRO_DATA and my display driver crashes and recovers.