Update the mobile app?

Mobile app is telling me to download an update after pre-patch launch, but there are no updates available! Will there be a new version of the mobile app, or is this just a bug?


Same problem here

Well according to https://worldofwarcraft.com/en-us/news/23492552/shadowlands-a-new-look-for-the-wow-companion-app, it was stated at the bottom of the page
The updated WoW Companion App is available for upgrade from the Apple App Store and Google Play with the release of the Shadowlands pre-expansion patch. Additional expansion features will be available with the launch of Shadowlands.

This is of course not true as I am having the same issue. I have also tried searching online for something from Blizz, but there is nothing to be found. My guess is, they broke the app and don’t care about pushing out the new app as it is probably not done. So we probably have to wait until SL releases whenever that is. (Probably next year).

1 Like

Same issue here. Ah well. Now we wait.

I just checked for an update to the WoW mobile app on my iPhone with iOS 14. The latest version available on the App Store is from 9/30/20. Hopefully the new version is pushed to the Apple and Google app stores soon.

Same problem here also

Seeing the same thing here.

I can confirm I’m having the same issue. Nothing up on the apple apps. Though I know they go they don’t post updates for iOS apps if they are buggy…so the previous posters comment maybe right.
I did delete it, and tried reinstalling it to see if they did the background update. Still same issue. Looks like they are taking servers down for maintenance again this morning, so we’ll have to see what happens after that.

By the looks of the email i got they have added a way to do old expansions wow apps. yay more gold!
Edit: Hey i am still 120! Neat!

It’s only neat once we actually have it. It is still broken, no update available.

I posted on Twitter, and BlizzardCS said the update is planned for the future…but no explanation as to why the broke the existing one in the meantime.


Yes, the companion app is currently unavailable today (Wednesday, October 14).

Simply put, we had a bug with the new version of the app that goes with the Shadowlands pre-patch, and we’re releasing an updated and fixed version soon.

The fixed version may be available in your device’s store before we’ve had a chance to do the WoW realm restarts that are required for it to all work.

After you’ve gotten the app update, and we’ve done realm restarts in this region, it should work as expected.


Thanks for the update, much appreciated.

1 Like

Checked this morning. App is not showing in the store at all now. Please come back soon :grinning:

1 Like

The update showed up for me about 7 hours ago. Just waiting for today’s maintenance at this point.

The update is there. When you search for the WOW app, in the list, the “open” button will be there. If you click on the app title to open its page, what was the “open” button is now an “update”. I updated the app. The app has this notice: [Incompatible Realm] “Server still updating to the latest version of the app. Please try again later”

And these guys wanted to go to developing mobile games, they can’t even build a phone app for an existing game.

Is there even a post in known bugs to let folks know that there is an issue. What a farce.

The companon app download itself is not showing in the Google Play Store at all. It’s like it was pulled or something.


Yeah I have the app on my Samsung phone but when looking in Google Play, it doesn’t show up anywhere at all. No update showing, not listed under my installed apps, and you can’t find the app when you search the regular play store for it. I really hope Google pulled it down to work on the update or something.

Blizz, can you tell us something about Google Play app?