Unable to Pet Battle

Try doing a full UI reset. Disabling addons doesn’t always remove the changes they make to the game.
Resetting the WoW User Interface - Blizzard Support

1 Like

I concur with Rufflebottom. Turning an addon off - or even disabling it is NOT the same thing as a proper reset. Addons live in a space that allows them to make changes. Sometimes old conflicts can still exist in that space, even without the addon running - or even being updated.

It’s a good first step to rule out anything of that nature, even if it doesn’t ultimately turn out to be the case.

With the massive changes that have just been done - I’d suggest everyone do this, even those that don’t think they are having any issues.

I was having the same issue and a few other weird pet battle UI issues and the only way i was able to do the pet battles was to turn off all addons while battling. Kind of a bummer to have to do it but … it worked.

1 Like

I disconnect on the first attempt of each pet battle, and these suggestions were not effective.

1 Like

Unable to pet battle wild pets. I can attack and kill but no pet battle icon shows up. Unable to battle pets for world quest in Nazjatar.

  • I have disabled all addons. Exit game. Re-log. Unable to pet battle
  • Exit game. Delete my addons folder. Re-log. Confirm, no addons option button as all addons removed. Unable to pet battle.

Should I re-install WoW and get a new computer just to be on the safe side?

Try a FUll UI reset from post #2 deleting addons wont fix a corrupted UI.

1 Like

Follow instructions from post #2 for a full UI reset and it does not solve the issue. Still unable to pet battle.

My pet battle limit now as 1,000 and also shows I have 1,010 total pets. Previous total was 1500 I think.

I am also being offered pet battle dungeon quests that I have already completed (and have achievements for completing).

Hoping Blizz takes the reports seriously and looks into it.

1 Like

Only if you filed a bug report. QA doesn’t take bug reports from the Customer Support forum and the SFAs here are not liaisons with them.

I agree. I always do a full UI reset at every “major” patch. For this patch, most of the addons I use (and it’s not very many) did not get updated for a little while (some late yesterday and others today). I know it can be time consuming to reconfigure everything, but I find it’s worth the effort for major patches.


Wash your hands. Wear a mask. Maintain social distance.

Both my sister and I were having issues where the pet bandages weren’t working to heal pets.
I wondered if anyone else had this issue.

Try resetting your UI.
Resetting the WoW User Interface - Blizzard Support
If that doesn’t work, file a bug report.

1 Like

Just as a point of information, I ran into this very problem (lost my pocket pet portal, capped at 1000 pets but had more than that, had to relearn pet battles, etc.) on both the Beta and PTR and I reported it. It wasn’t an addon or UI issue on there (didn’t have addons and did the full UI reset there too). It was a problem with my account as far as I could tell. Perhaps it leaked onto the live realms with the prepatch?

EDIT: There is a bug report out on it as well in the forums:

1 Like

The loss of items in the Beta and PTR has no relationship to the issue in the live game. It is not similar in any way. Missing items from there have to do with how the data gets copied to the Test realms.

Thank you for linking that.

no its always been 1000

There was also an achievement, AFAIK, that also awarded a companion cap increase, but it may have been removed in exchange for this.

Scratch that. This is that achievement.

There’s also this one, however.

The Pocket Pet Portal allows you to increase your maximum amount of battle pets to 1500.

Then the Interdimensional Pet Portal increased it to 2000.


This issue has nothing to do with the UI, and affects lots of stuff besides Pet Battles. There’s a thread over in Bug Reports where the common issue seems to be having executed a character transfer since the Pre-patch. There’s more information as well, though not much from Blizzard.

I am running into the same issue where I go to pet battle and immediately get disconnected when trying to enter the pet battle. Here are the things I have tried and the problem is still not resolved.

Deleted the WTF folder
Deleted the Interface folder
Deleted the Cache folder
Uninstalled programs such as Twitch, Zygor, and Tukiui
Disabled IPv6
Disabled antivirus
Used /console reloadui
I tried logging on to wow using a hot spot from my cell provider instead of my ethernet or wifi adapter.
Hell, I even uninstalled wow and deleted the folders where they could be:

  • C:\Documents and Settings\Local Settings\Temp
  • C:\Windows\Temp
  • C:\Program Files\gametitle
  • C:\Program Files (x86)\gametitle
  • C:\Program Files\Common Files\Blizzard Entertainment
  • C:\Users\Public\Games\gametitle
  • C:\Users\Public\Public Documents\Blizzard Entertainment\gametitle\

Needless to say that I did install wow after I did those things and still nothing worked. I had issued a bug report with Blizzard and contacted them about the issue and did not get the issue resolved.


I don’t know if anyone else has done this yet. and it is the weirdest thing. But if you go back to the Battle Pet Trainer…he is selling you the ‘pet battle’ skill again.

Like i already had the ability and suddenly i didn’t and now I can pet battle again.

Thanks for this wierd update Blizz that made me disable all my addons and believe you had a bug ( you still might because, why did I suddenly have to train for this again?!).


How does this even relate to the disconnecting issue that people have with pet battling?