Transmog broken after maintenance

I’m having this issue with my Druid for both the Claws of Ursoc transmogged onto a 2-hander and the Scythe of Elune transmogged onto a 2-hander. Oddly enough I have a dagger transmogged to Claws of Ursoc that’s working just fine.

1 Like

THIS IS THE FIX!!! remog your regular weapon with no enchant. then mog for legion item.

1 Like

Sorry, just tried that and it did not work for me. :frowning:

Adding my voice to this, I had my staff transmogged to Felo’melorn and logged in today and it was untransmoged and I cannot transmog it back. I can transmog it to the frost or arcane artifact.

1 Like

Why has this still not been fixed?


I am having the same issue on my Windwalker monk. I have a 2h weapon that I normally have transmogged as one of the Legion windwalker transmogs, but now I cannot apply that transmog.

1 Like

After I had been logged in for a few hours, I decided to try to transmog again. I removed the random illusion put on my one hander and then it let me transmog to my artifact weapon again. I guess it was a compilation of being logged in for awhile and removing the illusion that finally worked.

Just adding that I am experiencing this problem too. My staff was transmogged to the ele shaman hidden appearance, and I logged in to find it was no longer transmogged and it will not let me apply it again. The enchant fix did not work for me.

Bumping this thread. Druid staff that I’ve used for a couple months with Claws of Ursoc on it was reverted and no longer works.

Seems to be a legion artifact being transmogged over a different weapon type. On my druid I can’t transmog the legion staff over my 1h dagger. However in guardian spec my legion staff is working over my polearm. So not even weapon type, 1h vs 2h weapons.


Experiencing this on my guardian druid with a staff equipped and using the legion artifact fist weapons mogged.

It’s fine on balance/resto where I use a dagger/oh and use the legion artifact staff for those specs.

Same issue, so far tested on my windwalker monk and balance druid and it isnt letting me apply my artifact appearances

I think it was something with ToS. Until last Trial of Style and also during the Trial I was able to transmog my 2H weapon into my Artifact weapon (Fangs of Ashamane). Just after the Trial ended I can’t anymore. It shows me the cost which is around 152g although not even charge me or apply the appearance. My Kitty appearance (Skin) wasn’t affected at all by this bug. Already tried with all Addons disabled and did not work as well and by the way, before someone from Blizzard comes with an answer saying that 2H cannot be transmog into Fangs of Ashamane I can assure that I was doing that before and until last Trial of Style ended.

Yeah, I’ve tried that route as well. No luck.

Amazing, still not fixed. God dammit devs.

still isnt working for me either

Not working for me either. As usual, Blizzard hasn’t commented and doesn’t care.

Bump. Can’t transmog Xal’atath. :frowning:

Bump, come on devs, whats taking so long?

Having the same problem! I am using a dagger/shield combo on my Elemental Shaman. Prior to 3/30/21 maintenance, I had the weapon transmogged to the Fist of Raden appearance. Upon maintenance completing yesterday, I logged in and the weapon’s transmog appearance was changed to a different weapon (Bloodstained Ritual Athame) which I never set. I am no longer able to choose an artifact appearance for my dagger.

I think the worst part of this is that my weapon no longer matches my mog.