Transmog broken after maintenance

Add me to the “staff was transmogged into Xal’atah and now it’s back to a staff” group.


A full day later and the only mention of WoW from Blizzard is about Classic Era. A full day later and not one hotfix for a single thing after a weekly reset. And I guess this issue in particular will not get noticed, let alone fixed unless it becomes a top post on r/WoW or featured in wowhead news.

1 Like

hey maybe we’ll get a fix by 9.1!

1 Like

As it turns out, I was wrong. I didn’t think to actually, y’know, check my shaman before saying it was fixed for sure. I’m not sure why it randomly started working on my mage again, but this bear here is stuck with a dagger for now, I guess. :confused:

Hello? …

I submitted a ticket with GM regarding this issue yesterday and received a reply requesting more information today. While this doesn’t help fix the issue at the moment I did reply with a more detailed description of what’s going on and also included the link to this thread. I hope this brings attention to the issue from Blizz and a fix in the very near future. I will share any further relevant information I receive from the progress of my ticket.



Looks like some note has been taken of this issue, although it falls under another thread. Fingers crossed it’s fixed sooner rather then later.

1 Like

My experience is trying to transmog the chest piece, to Fireworm Robes. It will not change on my toon, but it does on my ‘mirror image’ toons. Weird.

The legion artifact appearances appear to be working now!

Nope. Still bugged. Still cannot transmog my staff into my mace+shield artifact appearance.

They do work when picked from a corresponding menu (i.e. picked from the staff menu). Are they working for you when you go to the drop-down menu, and pick ‘Legion Artifact Appearances’? Or are you picking from the corresponding menu as I mentioned above? It’d be helpful for the rest of us to be able to try to replicate your exact movements.

I currently tried again to transmog a staff to the Fist of Ra-Den via the ‘Legion Artifacts’ option; still no luck.

1 Like

It looks like this has also been picked up by WowHead finally:

Fingers crossed this means we will be getting a resolution sooner rather then later now.


Or allow us to hide weapons already.


Which appearance was removed from your alliance paladin?

I had a sword and shield transmogged as the 2h holy mace. Since the weapons are different types, it didn’t stick.

1 Like

It’s really sad that it takes getting bad press to get them to fix something rather than just fixing it.

I may have a way to fix this. I actually just completed the order hall campaign on my warlock this week and it was not giving me my artifact transmog which was the reason I did the campaign in the first place. I tried logging in and out and it just wasn’t showing up anywhere. I was using a different item that was transmogged to the first appearance. But when I tried actually equipping artifact item itself, I got the pink transmog alert and got all the appearances associated with it back in my collection. I had to do the same thing with scepter of sargeras and ulthalesh and I got the pink transmog alert for them and then all the appearances were in my collection. Then I was able to actually apply the appearances to my items again and interact with them on my yak (mystic birdhat). Maybe some other people can try this and see if it works for them? Try re-equipping the artifacts to get their appearances?

It’s a good thought, but I tried it with no luck.

I’m having the same problem. My staff was transmogged to Felo’melorn (Fire Mage Artifact) and now I can’t mog it back.

Hotfix went out.

Fixed an issue where two-handed Legion Artifact appearances were unable to be transmogrified onto one-handed weapons and vice versa.

And guess what? It’s still broken.

My staff still cannot be transmogged into my Resto Shaman artifact appearance.