The Amulet of Grol

I’ve been stuck on this quest in the Blasted Lands for quite some time. It would seem no one can interact with the “head of Grol”. Is there perhaps a work around for this?


I’m also having this bug. Others around the area have also reported it. The workaround others have proposed from… two years ago doesn’t seem to work either.

had the same issue, went and did a couple of other quests, came back, and was able to loot it.

This is still bugged years later! get rid of this quest and replace it if you can’t fix it!

1 Like

This quest is still bugged. Please fix :smiley:


I am having trouble completing the quest as well. I will try moving on and coming back to see if this works.

So I completed the tainted forest storyline in the south, and then came back to the amulet quest. I was finally able to grab the amulet.

The quest is still bugged as of November 24th 2019. Please fix this. Thank you.


Quest is still bugged. When interacting with the head on a stick in the sunken boat, I get the message: That is already being used.

1 Like

Still experiencing the same bug as mentioned above. The head on a stick is “already being used”

1 Like

Still bugged for me. How haven’t they fixed this yet? Sigh. :rage:

Still bugged with the same “That is already being used” message as of January 19, 2020.

Sill bugged as of February 2, 2020.

1 Like

Confirm bugged. Unable to advance the quest. When clicking on the “Head of Grol”, I get an error message: “That is already being used”. I’ve tried completing other quests and came back to it with no luck. Still getting error message.

Blizzard please fix.

same as the 2 from feb 2 2020, blizz plz fix

I am stuck on this as well. It’s frustrating as I need to do this quest for the Loremaster achievement. I even tried abandoning it and restarting and doing other quests and coming back to it…you would think they would fix this as it is part of the Loremaster achievement…

I was having the same issue as everyone else on this bug report - here’s what I just tried and it actually worked. I handed in the other two amulets first, then thought - what the hell, I’ll try it one more time - went back and clicked on the pile of bones/head-on-stick a few more times, got the same response “already being used” - then i hung around in there for about maybe 20 seconds, and suddenly it said, “you hear a noise behind you” and Grol appeared - it might be that we just need to take a bit more time for him to appear - like i wasn’t clicking the pile when he appeared.
Anyway, quest might be buggy, but this time it worked. I know sometimes they are the worst bugs when its not a consistent issue, but that’s what happened.

Tried this on my KT Druid nope. Still Bugged.

Lvling a rogue, and can confirm that it’s still bugged as of 2/27/2020. Why hasn’t this been fixed yet??

Bugged still. Going to try completing the other story lines and come back… fingers crossed.