Stuck updating-

this has got to be on blizzards end

Possibly, but I’m not sure. Both my kids just updated and had no issues. They’re playing right now. I, however, am stuck and can’t get the update to work.

Did all 3 of you update your game clients at the same time?

the update still not working for me and still giving me something went wrong error, i dont know if the twitch login way around works but that what i did and got in earlier, still i hope they fix this soon!

I just restarted my computer and launched the bnet app and it finished updating.

Edit: I had used tasked manager to close blizzard apps earlier so I though I didn’t need to restart my computer, but now I am glad I did so.

1 Like

Same as Asura. Tried the repair scan, power restarting the modem and all of that. Nothing. But restarting the computer fixed it and got it downloading. Probably should’ve tried that first. :sweat_smile:

yep, idiot me forgot to restart my pc, fixed the issue

I restarted my laptop and the issue didn’t get fixed tho, lol damm guess i am still screwed on my end

Yep. My update failed, my kids tried theirs right then and they worked.

Edit: Alright, fixed it. I’m in.

What I did:

  • First I just tried to redo the update. No luck.

  • Next, I did the scan and repair. Nope.

  • Lastly, shut down my computer and left it off for a few minutes, then restarted. The game then successfully updated.

Sometimes rebooting won’t fix an issue, but shutting down completely will clear any garbage lingering in memory.

1 Like

been troubleshooting right along for about the last hour down to scanning my pc for threats. no go yet. please help us!

Ok i will try to shut down 100% all the way then, Thank you!

FYI I logged back in using Twitch platform and got back in game,
using that until i fix the bnet issue lol



  1. Went to program data deleted the folder, as instructed by the error.
  2. This caused NOTHING to work (It wanted to reinstall wow and bnet) and I panicked like crazy at my guild via a third party program.
  3. I calmed down and restored from the recycle bin.
    3.5 (because it might be important and i forgot about it a second) I replaced the 19 or so files it questioned me about rather than skipped them.
  4. i booted wow again
  5. BOOM- patch installs flawlessly. fixed.
1 Like

I was having the same issue with the update not installing(multiple times). So, I Followed the directions of scan and repair, but still no luck. So I did SHUTDOWN (not restart) my PC. After booting into windows, BNet did the update again and was successful.

Hope this helps!


I’ve selected the option to verify and scan and it deleted my data folder, now I’m downloading the entire game again, thanks Blizz!

Just throwing my name to the list… I have tried to repair, reinstall Battle dot net, and now just reinstalling the game. Will post if that solves it.

Read this too late! :frowning:

That worked for me earlier, now it says there is an update and takes me to the bnet launcher to fail again :frowning:

Good news (so far at least), I didn’t have to restart my computer, just closing out the Bnet app for a few minutes and reopening got the patch to download!

Another way to prompt an update if it won’t automatically check for updates is using thescan and repair option.

That said, it looks like the original poster never replied to this thread, and there aren’t any widespread bugs causing this. More often than not it’s an installation error. If the scan and repair fails, you can check this thread for more ideas for the install/patch problem, and start your own for help if it doesn’t work.