Stuck in combat in Mechagon, FOR...EV...ER


(Elopeppe) #51

There’s some bug internal flag that’s bugged. I’ve found on a couple occasions that I could not use the flight master. I wasn’t in combat, but trying to select a flight point would result in a message along the lines of “You are currently busy and cannot use the taxi service.” This has happened both in Nazjatar as well as Kul Tiras prior to 8.2. Invis did nothing to help, nor did waiting 5 minutes. In the end, I could only log out and back which served to reset whatever was bugged.


#52

You can Alt+F4, Ctrl+Alt+Delete, or any of the other things that work and force-quit the game. A few minutes should be plenty time for Blizzard to log you out on there end once your connection goes dead. Probably take less time than waiting for AFK to axe you. Also, Hearthing and Zoning worked for me, most of the time. It just made the game grind to a halt, again, and again…and again…and again…


#53

My favorite is when I’m just standing there, with nothing hostile within render distance, and I just enter combat randomly.

I stopped trying to figure it out a very very long time ago. It’s just one more thing about the game that is inexplicably broken.


#54

I had this before, sometimes it could be because of the follower in nazjatar, its a weird bug where you are not in combat but because your follower is in combat, you can’t use the FP. It’s a really annoying at times =/…


(Cinderflame) #55

Have you ever played havoc? As havoc, pulling 18 things at once isn’t a ‘tank’ thing, it’s just an everyday thing. Three elites and 6 normal mobs? No problem. Solo a rare? No problem. The only things that make me blink or hesitate are the new 122 rares, but even then, if I’m in trouble, I just pull more.


(Kaivax) #56

We’ve been following threads like these very closely. Please feel free to detail any new occurrences of this issue in this Bug Report thread.

Thank you!


(Bipölar) #57

I had to hearth back to the inn just to get out of combat from one side to the other. One of many reasons I quit this Korean dev team game.


#58

OP - can’t drop combat despite doing everything possible to try, clearly something Blizz should have fixed years ago and won’t fix for years to come.

Others in this thread - proving why Blizz will never fix it, by getting on the OP’s case and fanboyishly defending Blizz’s broken content.

This is why this game sucks right now- players aren’t just accepting Blizz’s broken content and overall laziness, you’re downright celebrating it.


(Argorwal) #59

This has happened to me multiple times as well and i ended up having to hearth each time.

Once it happened from attacking the first mob off the alliance flight path. Could never leave combat.

Only on Mechagon.


(Orctang) #60

Yeah, I got stuck in combat for a really long time on Mechagon as well… I had no idea what I was in combat with and I think I had to finally hearth to drop combat.


#61

With all the issues can we get a discount on sub fee?


#62

Hey, there. I’ve experienced both the very same instances of being stuck in combat in both the specified areas above, but as well figured out what was causing them to remedy it myself, when it happens.

Near Seaspit/Freza, typically (myself included) people tend to just rush past the mobs fighting each other to engage with the rare. However, they’ve actually aggroed you, but since they’re fighting each other, you never notice, and because the mobs remain indefinitely “in-combat” without evading/leashing due to their battle together, so do you, indefinitely.

In the other instance on the main island, the offending mob is actually the flying crates. They may “aggro” you, or you may hit them by accident fighting other things around Bondo’s yard, but as they have no attacks or indications that you’ve engaged onto their table, you’ll again remain indefinitely in-combat until you find that crate and finish it off.


#63

Hey Blizzard, please feel free to actually try doing something YOURSELVES!

Given the long-term, widespread and large-scale nature of this problem it’s inconceivable that no-one from your dev. team couldn’t repro this inside of 15 mins … HOW ABOUT TRYING?


#64

Strange, I haven’t run into this issue on my DH. I’ve only explored Mechagon for a grand total of about 3 hours though, so it may be a matter of time. It’s not for lack of trying. I run through all the things.


#65

This has been happening to me all of bfa but it’s the worst in mechagon either hearth or die.


(Azreluna) #66

Just FYI, you wrote this backwards.


#67

I’ve spent easily over 20 hours in Mechagon and never have had an issue either. I’ve been there at least an hour a night, if not 3 hours, most nights (makes me realize it’s way over 20 hours but to lazy to do math right now).

The only mob that will chase me any distance really outside the norm are the bot guards you get aggroed from attacking players in the hub near the fp.

If this is happening it sucks, but I’ve never seen anyone complain in general chat or anything for all the time I’ve spent there.


#68

Usually if I’m stuck in combat, it either drops after I swim out for a bit, or I kill the nearest enemy and combat drops. Doesn’t happen too often, but it does seem to happen more on hills or mounds of junk in Mechagon. Probably a mob stuck under the world that you can’t see or reach, but it can still reach you. Fun stuff.

P.S. If i had to die or log out to escape combat every time, I’d probably stop playing altogether.


#69

Being stuck in combat increases the time played metrics, which Ion can show on the chalk board at the next shareholder meeting.


#70

I experienced this issue as well multiple times typically on the 3 islands. I even tried force closing the game but when i logged back in I was still in combat.

I was required to hearth back to Boralus for it to drop.