Reticles/Ground Targeting Spells Not Working

As of today I cannot consistently use reticle effect spells (efflorescence, mass dispel, shadow crash, blizzard, etc.) on any character. They give an “out of range” error. It started today after the small update, and it is not an issue for any of my friends playing on PC. It seems some terrain works fine and others it isn’t registering it and therefore isn’t clickable (for example the main couryard in Valkdrakken is problematic but the stairs up to the Seat of the Aspects and inside seems to work fine). It’s making a lot of class/specs impossible to play at even a moderate level, and I’m fairly certain this is another update that was pushed through without Mac testing and is only affecting the Mac player base (and potentially again only certain operating systems, like the last issue a few months ago). Hopefully someone can figure this out during maintenance tomorrow, because the last time we had a Mac specific issue it took weeks to sort out.

1 Like

Same! Very difficult to play as some areas of the screen allow spells placed and others grey the mouse out and do not allow spells placed.

Mac OS 13.3.1

I made this a while back. Also experiencing the same issue.

I’m having the same issue as well. This needs an immediate fix, it makes any kind of group content literally unplayable, as you can’t do your AoE rotation as a frost mage.

1 Like

Same here… Warlock can’t cast Rain of Fire… on a mac

Mac user as well and having the same issue with Holy Word: Sanctify, Mass Dispel reticle ground targeting. I just noticed this issue today while running a timewalking Eye of Ashara.

Valdrakken seems to be really buggy in terms of targeting. If I stand inside the Roasted Ram Inn the targeting seems to work fine but once I go out into the courtyard as the OP stated the terrain seems to cause issue. I hearted to Legion Dalaran and the ground targeting worked fine there.

Also tried turning off all add ons and the issue still persists.

Mac user here, same problem. Can’t cast blizzard, ring of frost, ring of fire, or frozen orb. Game is unplayable at the moment.

Mage tower is always there, its not only during legion timewalking. They’ll fix it - but don’t worry about any time restraints on you.

1 Like

Same issue here. Again Mac user, trying to heal on M+ 18 is really taxing. Can’t cast efflorescence consistently. Same ground effect issues noted, particularly red backgrounds. Have disabled addons, rebooted computer, repaired Blizzard files etc. Thanks for posting as I couldn’t work out why this has arisen.

love this comment, Did not know that you saved me from a poor start to the day ty sir.

Anyone had any luck finding a solution to this?

Can also confirm also having the same issues on Mac, First noticed it on the PTR with Heroic Leap but have since seen it on live also with other spells.

It seems to depend on the type of ground/floor. Some areas will be fine but then moving the mouse to another area, usually like a rock or some kind of object makes it work.

certain spells are borderline unusuable atm
shud be priority to fix

Same issue here, cannot use shadow crash and Final reckoning, MAC user as well .
we experience the same issue when testing PTR yesterday.
Video how cannot cast Final Verdict

Same. this started happening last night on the 24th. Mac user as well. Redownloaded the game and tried it with fresh wtf add-ons and cache folders and still had the problem.

1 Like

Same situation noticed on 4/25 trying to cast Volley on my Hunter. I also noticed that “click to move” will all of a sudden not work and requires a log out/log in to reset. Come on Blizz, buy your programmers a Mac so they can test for things like this.

This seems to have been fixed today. Not seeing the issue anymore.

also fixed for me, thank you devs lol

Looks like they reverted the game client to previous version :slight_smile:

Yeah, looks like it might take a bugfix to get this out of the way. Was really hoping it was as simple as a setting that could be changed. :frowning: