Prophet Skeram disabling buffs & passive talents/glyphs/racials

The Prophet Skeram in AQ40 is disabling all buffs and also all passives from talents/racials/glyphs upon activating the 2nd split phase at 50%. The first split phase at 75% worked fine.

https://classic.warcraftlogs.com/reports/g7KHNyLPMr9R6dxQ/#fight=2&type=damage-taken&view=events
Take a look at the following entries at 0:25 and 3:39:
00:25.597 The Prophet Skeram Earth Shock Corpsetwo 2202 (U: 2730, M: 528, 19.34%)
03:39.810 The Prophet Skeram Earth Shock Corpsetwo 893 (A: 1256) (U: 2664, M: 515, 19.33%)

The percentage at the end of the line refers to the percentage of damage mitigated. In my situation, this comes by multiplying all of the following effects:
Improved Righteous Fury : 94% damage taken
Blessing of Sanctuary : 97% damage taken
Guarded by the Light : 94% spell damage taken
Shield of the Templar : 97% damage taken
Glyph of Divine Plea : 97% damage taken

Multiplying 0.94 * 0.97 * 0.94 * 0.97 * 0.97 = 0.8064378628 spell damage taken, which is equivalent to 19.35621372% spell damage mitigation, which agrees with the combat log entries.

This is meant to prove that I have all of these passive effects on me early in the fight.

https://classic.warcraftlogs.com/reports/g7KHNyLPMr9R6dxQ/#fight=2&type=auras&view=events&spells=debuffs
Ardent Defender procs on me at 1:24.300. Note that the debuff faded at 3:24.299, 2 minutes afterward.

https://classic.warcraftlogs.com/reports/g7KHNyLPMr9R6dxQ/#fight=2&type=healing&view=events&ability=66235
Said Ardent Defender healed me for 8175 HP.

https://classic.warcraftlogs.com/reports/g7KHNyLPMr9R6dxQ/#fight=2&type=healing&view=events&ability=31852
Here’s the Ardent Defender passive damage reduction in effect.

https://classic.warcraftlogs.com/reports/g7KHNyLPMr9R6dxQ/#fight=2&type=auras&view=events&sourceclass=Any
Here’s my buffs for the fight. Note that at 3:43.054 I lose the following buffs:
03:43.054 Corpsetwo’s Righteous Fury fades from Corpsetwo
03:43.054 Corpsetwo’s Retribution Aura fades from Corpsetwo
03:43.054 Corpsetwo’s Seal of Vengeance fades from Corpsetwo
03:43.054 Corpsetwo’s Greater Blessing of Sanctuary fades from Corpsetwo
03:43.054 Corpsetwo’s Divine Plea fades from Corpsetwo
03:43.054 Corpsetwo’s Sacred Shield fades from Corpsetwo
03:43.054 Corpsetwo’s Sacred Shield fades from Corpsetwo
03:43.054 Corpsetwo’s Libram of Obstruction fades from Corpsetwo

I did not hit a cancelaura macro or anything like that. I specifically disabled all of my addons for this boss attempt.

https://classic.warcraftlogs.com/reports/g7KHNyLPMr9R6dxQ/#fight=2&type=casts&view=events&hostility=1
Here’s a list of the enemy casts for the fight. Note that the 2nd split occurs simultaneously with me losing all of my buffs.
01:09.287 The Prophet Skeram casts Summon Images (1st split)
03:43.054 The Prophet Skeram casts Summon Images (2nd split)

Recall the 19.35% spell mitigation from before. One combat log entry showed that at 3:39, I had the full suite of spell mitigation. Yet, at 3:45, the following line implies that I have exactly 0 spell damage mitigation:
03:45.077 The Prophet Skeram Earth Shock Corpsetwo 2126 (A: 500) (U: 2626)

While some of this can be attributed to the missing buffs above, some of the missing spell damage mitigation effects are 100% passive. Shield of the Templar talent reads as follows: “Reduces all damage taken by 3% and grants your Avenger’s Shield a 100% chance to silence your targets for 3 sec.” There is nothing conditional about that. The Guarded by the Light talent similarly has a purely passive damage reduction.

At 4:08 I die to one of the clones’ Earth Shocks:
04:08.981 Unknown Actor 3 Earth Shock Corpsetwo 2432 (O: 40) (U: 2548, M: 76, 2.98%)
Recall that my Ardent Defender activated at 1:24.300 and the associated debuff faded at 3:24.299. Here, I take a killing blow 44 seconds later, but Ardent Defender is nowhere to be found. It didn’t activate at all, even though there’s no reason for it to behave as such.

03:50.426 Corpsetwo gains Blessing of Sanctuary from Corpsetwo
I reapplied Blessing of Sanctuary at 3:50, which gave me 3% damage reduction.

03:51.159 Unknown Actor 3 Earth Shock Corpsetwo 2648 (U: 2730, M: 82, 3.00%)
At 3:51 it’s evident that the damage reduction took effect.

04:00.693 Corpsetwo gains Divine Plea from Corpsetwo
At 4:00 I re-applied Divine Plea, which should’ve activated the Glyph of Divine Plea for 3% extra damage reduction. However, this damage reduction didn’t take effect per the below:
04:04.115 Unknown Actor 3 Earth Shock Corpsetwo 2577 (U: 2656, M: 79, 2.97%)

After running back to the instance and rezzing, this screenshot was taken:
https://i.imgur.com/a3rREoN.jpg

After taking the prior screenshot, I relogged. After relogging, this screenshot was taken:
https://i.imgur.com/0aFGx4Q.jpg

Note the following discrepancies in my stat page and health bar:
Max Health : 27284 after rezzing, 29384 after relogging. Note that the Protection tree gives several stamina bonuses.
Crit Chance : 5.94% after rezzing, 15.94% after relogging. My spec gives 10% crit from talents: 3/3 Combat Expertise (6%), 2/5 Conviction (2%), 2/3 Sanctity of Battle (2%).
Expertise : 17 after rezzing, 26 after relogging. The Combat Expertise talent gives 6 expertise, and the Sword Specialization Human racial gives 3, for a total of 9.
Dodge : 16.09% after rezzing, 21.09% after relogging. The Anticipation talent gives 5%.
Parry : 13.94% after rezzing, 18.94% after relogging. The Deflection talent gives 5%.
Armor : 23032 after rezzing, 25180 after relogging. The Toughness talent gives 10% armor, although this only applies to the armor granted by items.
Power : 2140 after rezzing, 2428 after relogging. The Divine Strength talent gives 15% strength which converts into Attack Power.

As shown above, relogging restored all the proper passives to my character.

4 Likes

Just wanted to 2nd this. Trying to solo as a warrior and ever after the first split when the adds are in range they are spamming earth shock. If their top threat target is in range they should not be using earth shock.

Also 2 manning it I am experiencing the same issue as above. My glyphs break after the Tank gets MCed and I also can no longer use revenge. Reloading does fix it but its is making this boss impossible to solo or 2 man.

FWIW this was also happening with the prepatch Zombie Invasion mind control from catching the plague. There’s a good chance that other miscellaneous mind controls cause it as well.

Here is a screenshot after being turned into a zombie showing that I have 36 spellpower coming from 2 ring enchants and a +12 sp gem in the neck, but the other spellpower, such as from Quagmirran’s Eye, is missing:
https://cdn.discordapp.com/attachments/917117238371291166/1017881222279602206/unknown.png

This was also completely disabling talents like Maelstrom Weapon; it simply would not proc until a relog.

1 Like

Between the MC breaking everything and the adds spamming earth shock when they should not I’m not having any luck soloing or 2 manning it :frowning:

I have been trying to solo this boss as an enhancement shaman in WOTLK Classic, and I have experienced a similar issue at 50%. My attack power and spellpower, health dropped dramatically. Fire Nova cooldown increased from 3 seconds (talent+glyph) to 6 or sometimes 10 seconds.

None of the talents or glyphs seem to work until I change between my dualspecs after I’ve rezzed.

I have not tried it in 1-2 weeks, so I don’t know if a patch has happened or not yet, but in the period of the OP to possibly the present, I can confirm it’s broken as well.

Still not working. Happened to me yesterday.

1 Like

Still broken

2 Likes

This is still broken. I have been trying to solo Skeram on my paladin and was curious as to why I was dying so fast on the 50% add spawn compared to the 75% one. I observed carefully a couple of times at this step, and all three seem to spam Earth Shock despite being in melee range. Additionally, I noticed that my talent that refreshes Divine Plea when I hit an enemy doesn’t work, my Blood Elf racial passive of +10 enchanting is gone (as is seen from only having 390 enchanting +10 racial bonus and my ring enchants that need 400 enchanting going red when the 50% adds spawn), and my flask and other buffs are gone. It’s as if everything about the character just drops off. Please fix!

1 Like