Pity the Fool Broken in Arathi Basin

The achievement gives no credit when you /pity the love fool right in the middle of the blacksmith building. Other users have reported the same issue.


Came here to post this as well. i dropped 2 boxes and still did not get credit. i really dont want to keep farming these charms for nothing…


I am having the same issue, and currently trying to open a ticket about it. I did one just outside the building and another inside and spammed /pity while targeting the Love Fool in two different runs. Have someone in my group have the same trouble.

1 Like

Hopefully it gets fixed quickly. I really don’t want to wait until next Feb to finish this achievement.


YES,Other users IS ME
don’t worry
I wrote to customer service

1 Like

Yea bugged for me as well. I tried 2 Love Fools, 5 hrs apart and got nothing. I went back and looked at previous comments and this seems to be a yearly thing with Blizzard. It was bugged last year and the year before that. This is infuriating.

1 Like

Did they at least fix it those years? Or has it been broken the last 3 years without a period where it worked do you think?

1 Like

Came here to say I have the same problem. I put down 2 and didnt work… :confused:
Had to put a ticket in too. Ugghh…

1 Like

Gonna toss in my part here as well, dropped one and neither of us got credit. Won the BG but was still no dice.

1 Like

Yeah having the same issue here dropped mine twice no dice now I have to wait until tomorrow to get more tokens to try again.

1 Like

I hope it is fixed soon, it is literally the last thing I need for my violet proto

1 Like

Adding my bump to this, I submitted a ticket to Blizz in hopes of getting this resolved as this is the last achievement for The Love Fool AND for my What a Long Strange Trip meta achievement… it’s infuriating having dropped 3 of the dummys only to look like a dummy myself and not get the achievements!


Same, done this yesterday with no achiev progression (Was actually supposed to be posted by Darknfuzzy - hakkar incase this matters in the long run)

Just tried this. Dropped in AB Blacksmith area. /pity

Nothing. Submitted an in-game bug report. Hope they fix this soon. Last thing I need for the Love Fool achievement.

Yeah I tried 3x trying to do it when it was under Horde control, No control and under Alliance control of the area and got nothing.

Seems like an issue for everyone then? I see on the Wowhead Love is in the Air guide they put that it was bugged back in 2017. Can anybody confirm they actually completed this achievement the last couple of years (2017-2020) or if it has been bugged for a continuous several year period without a fix? This really would destroy the effort I put in so far for Long Strange Trip and I only have a couple of holidays done. I can’t imagine how upset I’d be if like some of you it’s the last achievement I need.

Just received a response to my ticket:

We are aware of an issue where /pity on a Love Fool in AB is not giving characters proper credit towards the achievement, “I Pitied the Fool.” We have sent the issue to the WoW team to review and resolve.

In the meantime we are asking our players to try this achievement again a little bit later. We aren’t able to give credit for this part of the achievement or reimburse for the used Love Fool items.

We expect this to be fixed later this week…


Ok, so I JUST got a response to my submitted ticket and it’s a bs excuse and automated thing… “wait til later in the week to try again, we can’t do anything to help” essentially

1 Like

Blizzard is on some straight up bullsh1t. I’ve been working on What a Long Strange Trip on and off for the past 11 years. This is the final chieve I need to get my Violet Protodrake.

Even worse, Blizz knew in previous years that this is a commonly occurring bug and they still went ahead with the Love Fool event.

I did read that in the previous years when it was bugged Blizz did do hotfixes to the game which allowed players to finally get the chieve. Its just a waiting game now.

1 Like

Please fix this ASAP.

This is currently the last thing I need to do to get I Pitied The Fool achievement and the Love Fool title. I do not want to wait until next year to get it done, if I will be playing next year that is.

I attempted twice and another guildie got the same problem while trying on his own.