Nvidia Driver 465.89 killed my framerate

In Retail, I went from a locked 60 FPS @4K to 20ish FPS at the same resolution after installing the new driver. Reverting to the old one fixed the issue. Anyone else experiencing that?


Most of the complaints about the Nvidia drivers after 460.xx are about flickering, not specifically about framerate.

1 Like

I also have had terrible framerate since updating to the new driver.

1 Like

It seems the new driver, at least on my PC is causing WoW not to detect the Nvidia card. It keeps trying to use the integrated Intel GPU.

You are not alone, my Rig was humming away all expansion except now, seems to be a combination of a few things coming together. Somehow between Nvidia’s driver update, Windows new 20H2 update, and some change in Blizzard’s implementation of DX12 something broke. My computer has gone from somewhat evenly spreading the extra work around all the other cores, to just pegging one core hard and lightly working others. My GPU barely registers a load, sometimes the load is so low, it shuts off all 3D clocks and runs at idle speed. I have managed to get around this by altering the Nvidia profile for WoW.exe with Nvidia inspector, still dont give full boost clocks but atleast its not running at 800 Mhz.

Observations: (I really haven’t had enough time to flesh out what is wrong, like reverting to older drivers, or reverting back pre Windows 2H02 update, to rule blizzard out) All roads do point to something wonky in Blizzards implementation of DX12. See if you run the game in DX12 mode it pegs one core and barely uses the full power of the CPU or GPU, still running at a passable state. If you switch modes to DX11 BOOM, 3D Clocks pick right up and the CPU starts to see an even more even spread of core usage. The machine is being used by the program as it should be when in DX11 mode. DX12, Boost clocks are dead, Nvidia card wont go into P0 or P1, it will stay in its P12 state

Now, under DX11 there will be a small FPS drop due to how it works, but at least it’s stable.

SOmehow under DX12 and Blizzards implementation of it in the current iteration of Windows updates + Nvidia updates is not making it work, its treating my machine like a single core machine with an integrated GPU.

I say it’s Blizzards implementation because, ALL my other games Hit boost clocks and push the GPU to the maxx. Wow is the only game that makes poor use of my CPU lately, and extremely poor use of my GPU.

I had this issue recently on my backup machine which is a laptop, make sure you are in the correct power plan and in your prefered GPu settings make sure the Nvidia GPU is selected.

I’m having the same issue. I also reverted back, which did fix the issue, however this evening it’s doing it again, and I have not redownloaded the driver nor has my windows updated. I do run ElvUI, but updated that and the issue did not fix.1 fps just standing still at the mission table. I am currently on driver 461.40

I usually wait for the studio driver.

I also have started experiencing this issue in the last week. My framerate is about 50% of what it was before on my 1070ti

I’ve figured it out on my end. I run Black Desert Online in the background, have since I returned to WoW last august with zero issues. Well, after installing 465.89, then reverting back to the previous other driver (461.40) with the FPS issues, it appears I can no longer have both games open at once. Can’t even have BDO running while in tray. The frame rate for WoW drops and stays below 20 fps. I think when I originally checked my WoW fps after reverting, BDO was still off after having to get out of it with changing up the drivers.

So… in essence something with the 465.89 driver version broke my Nvidia GTX 1650 and/or PC (i have a ryzen 5 2600 six core series btw) ability to handle both games at once, and reverting back to the previous driver (461.40) did NOT fix it.

1 Like

Reverting to 461.72 fixed my framerate in WoW… not sure about running two things at once.


So, after more fiddling around, I discovered that while reverting back to the previous 461.40 driver, Geforce Experience was telling me to install said driver. So, I decided, why not try a clean install of the 461 driver? Didn’t give me the option (after checking under the advanced option), so I express installed instead. (i never had to revert back to a driver before, so didn’t know i had to reinstall it and/or some elements of it)

This does APPEAR to fix the FPS. I can run BDO in background with diminished FPS (~35ish FPS, usually lower going to 20-mid 20s FPS) BDO IN TREY gets me 40-50FPS, where I was pre-install of 465.89 driver.

I also lowered some of my ElvUI settings. (just the target profiles to 2D instead of 3D and Overlay).

Hope this helps others.

The diminished FPS in the background is due to the hidden settings you can only access via Nvidia inspector, it sets your background FPS to something low. You can change that.

Something is not right with WOW and DX12, every other game works fine. It will run at 120 FPS for me, but it’s barely giving my Video Card any work to do, it’s making the CPU do all of the work. Before it wasnt that way. If I flip it to DX11, everything starts to work correctly.

My PC is a desktop. It is running on the high performance profile. As soon as I clean installed the previous driver, everything worked fine. It seems to be the 465 series driver that is causing various issues for random people. I checked Nvidia’s driver feedback thread and there are numerous issues being reported.

I’m on 461.09 driver currently, I’ve noticed a big increase in microstutters after 9.0.5. Can literally stand still in an empty area, with 180ish fps and move camera around with A or D. On a 360 degree spin, I get like 2-3 stutters kinda consistently.

Thats WoW’s Currently Broken implementation of DX12, it saturates one core and one CPU Thread to 100%. Try switching your APi to DX11 seems to be doing multithreading better for some reason. Also, Windows did something to their power profiles and how the computer is handling idling down, spinning down, and Parking hard drives. It will bring the system to a complete halt to spin-up and unpark a physical hard drive. So if you have spinning disks, check your power plan and turn of Spinning down hard drives.

Good luck, I myself resorted to Up-scaling the game render to 200% to stop my graphics from going idle. Barely waking my GPU up.

Not sure if this will help anybody else but I just noticed (sorry I’m old ) that it says “Windows OS Now manages selection of the graphics processor” in the Nvidia Control Panel. Once I clicked on the Windows graphics setting link in there it took me to Windows 10 graphics setting and under Graphics performance preference I used browse and chose wow.exe (it should be under C:\Program Files (x86)\World of Warcraft_retail_) and set it to use Nvidia (high performance) my problem seem to have gone away. Seems like they ninja changed the way it works, hopefully this helps somebody else;)

If you have one single GPU you shouldn’t see that option. If you are on a desktop, your iGPU might be enabled, which leads to a whole set of “Different” issues. If you are on a laptop with an iGPU and a discrete GPU then optimus is enabled, and windows attempts to manage who gets to run on the discrete GPU while everything else is ran on the iGPU.

The problem is a conflation of several issues, Nvidia looking for an edge above the AMD cards, moved frame scheduling to the CPU as a software implementation, to free up for GPU to render frames. This breaks a feature windows put out during the 1080 Ti series, where windows stopped scheduling frames and let the GPu handle frame scheduling.

Under Settings> Graphics Settings You will see a feature called Hardware-Accelerated GPu scheduling.

That feature was supposed to move most of the GPU scheduling to the GPU, Nvidia in their awesome wisdom decided to “Do the scheduling”, So they did, the GPU acts as a frontman for a piece of software actually being ran on the CPU under an “Nvidia Container” as a background process, the feature actually worked very well. When it was handled by the GPU actually giving it work to do. Now on a title like wow that depends on the CPU, and not the GPU, it comes to bite us users in the rear, because Nvidia wanted a marginal at best increase in FPS for other GPU intensive titles for the 3XXX series cards… which almost no gamer owns.

This is the big stink caused in the hardware community a few weeks ago, where it was found that if your CPU is not the “Top of the line flagship” you get more FPS from AMD cards, if your CPU is a Flagship model then you might see marginal gains in the same title using an Nvidia card. Because the Drivers use your CPU to “DO work” the GPU should be doing.

So for Example, if you Have a Ryzen 7 1700, and you upgrade from an RX 570 to an RTX 3070… You will see a massive FPS and performance loss. Why? Well the Nvidia Driver, is Pretending to do the work on the GPU (at least windows thinks it is), but the work is actually being done in software on your CPU by the driver.

Ask Nvidia what the problem is on their forums… “Get a better CPU”, ask a normal person with your interest as priority… return the GPu to store and get an AMD that will not tax your CPU for heavily for a marginal gain. The performance gains based on your CPU are nothing to scoff at either… 30% Improved performance just by ignoring Nvidia if you don’t have a mortgage level CPU.

Hardware unboxed really dived deep into this issue, Nvidia was livid they actually went in and did a full on editorial on this specific “feature” introduced in the 3XXX series.

If you are into subjects like this… Here is the Hardware Unboxed video that goes into detail about the Driver overhead issue.

So a title like WOW, which is CPU limited, this matters, I still think Blizzard has some fault in the recent shenanigans because it’s the only game that fails to make my GPU even blip once at normal settings, it has something to do with they way they are using DX12’s API. If you flip the game to using DX11 the whole animal behaves wildly different, it actually starts using more threads and cores; instead of burning a single thread to 80% while the rest of the CPU is asleep on DX12. I have to run the game at 200% Upscaled resolution to get my GPU to put in some work. So right now my 2560x1080P is actually rendered to 5120x2160 (200%), still getting about 160 FPS. When the CPU gets busy in raid, of course that tanks to like 100 to 120. As long as it stay above 60 I am alright with that.

It’s the only game that does this for me. Metro Exodus, GTAV, SHadow of the Tomb Raider, Deus Ex, HItman, Far Cry, Red Dead Redemption… All run just fine. … wow on the other hand, it taking epileptic dumps in it’s pants because it doesn’t know what to do with the darn hardware. I’m not falling for it this time, last time I upgraded was this very reason, wow refuses to use all the resources you have, so you have to go out and buy flagship level stuff so it can only use 25% of it. It’s tolerable for now, with this market… Scalpers, Miners, and Corporate overlords milking us for 2% improvements every 3 months;… just not that interested in buying anything right now. Not at the 500% above MSRP levels everything is at.

Laughed my rear off when all the scalpers went to all the retailers, gobbled up all the 11900K’s CPU’s… then the reviews came home to roost. Congratulations… the 11700K you left on the shelf was the actual value. They are still trying to sell these things to uninformed people at crazy markups, on all the different social media marketplaces. Love it… they artificially created market scarcity, for a product not a single actual power user is interested in buying.

Hey Carka. This seems to have lessened the amount of stuttering, so thank you. Can I please ask what version of the Nvidia driver you are running in conjunction with this settings change?

Since you mentioned ElvUI I’ll just say that in my personal experience, using their nameplates caused a MASSIVE drop in my FPS. I run 4k on a high end rig (3090rtx amd 5950x). In orgrimmar using ElvUI nameplates vs KUI dropped it 20fps. In other areas like Ashran it was almost nigh unplayable at sub 20fps. So if you do happen to have ElvUI nameplates on, do a test and disable them in an area like Org (or Stormwind) with a lot of players and see if it has a big impact. If so, I’d suggest finding a different nameplate option. Just throwing that out there since you mentioned FPS, even though this isn’t related to drivers.

1 Like

Wow, you may have just fixed my recurring issue. The single digit FPS kept coming back. I would fix it for a day, but overnight it would seem to happen again.

I do believe I saw your post in ElvUI forums when I went looking yesterday after my FPS drop came back. Tho I always have friendly (same faction) name plates disabled to help in BGs. Not saying it’s not the case, after all, the graphics driver and ElvUI may not be playing nice together. I’ll try trouble shooting through that if the FPS drops come back.