Netherwing Drake Black Scales missing

The new meta achievement “Now THIS is Dragon Racing!” says that it rewards Grotto Netherwing Drake: Black Scales. I completed the achievement today but I did not receive the manuscript and it is not in my mailbox. I have tried logging in and out.


Seems nearly ALL of the new or retroactively mount rewarding meta achievements are bugged like this.

Have not got any of the mounts that were retroactively put onto already existing achievements or any of the mounts from the new metas except the Calescent Shalewing.


Just completed the achievement. I logged out on the character, logged back in, checked my bags, checked my mailbox, checked the Rostrum of Transformation… the Netherwing Black Scales are nowhere to be found. Pretty disappointed since I just spent hours doing the races I had yet to complete.


Ditto here, friend and I just spent three hours finishing the races I missed only to not receive the manuscript. :I

Yeah, I spent 2 hours doing it as soon as the servers came up because I was so excited. Netherdrakes are my favourite mount in the game so this was really disappointing! Here’s hoping they just fix it and mail us the scales instead of deleting them again like they did with the Green and Black back in November.

1 Like

Can confirm that the only working mount in 10.2.6 was Zovaal’s Souleater for people who had Veilstrider title. All other Meta achievement “Bestowed” mounts are not given retroactively OR rewarded upon completion. Neither is the black scales as reported here…

Still nowhere to be found even after their maintenance today. Really looking forward to finally getting it.

Chiming in. Logged in because I saw that the meta achievement was added for the black scales for the Grotto Netherwing Drake, and I do not have them. The option is not available at the Rostrum. Etc.

Need some kind of information on this.


I also completed the achievement yesterday (March 19th) and did not receive the manuscript as a physical item. I didn’t check the Rostrum yesterday but today after logging in I went to the Rostrum and the Black Scales are now an option for my Grotto Netherwing Drake.

So, if you earned it check your Rostrum again, it may be an option. But, if you earned the achievement before 10.2.6 went live it might be like all the other meta achievements that were added and the reward has not been properly granted yet

I earned mine just this morning and don’t have it anywhere. I’m really looking forward to finally having the black Netherwing scales and bummed its glitched like this atm.

1 Like

I also completed this achievement after shutdown last night and the scales showed up in the Rostrum for me, but my wife finished it before shutdown last night and she does not have the black scales in the Rostrum so they didn’t retroactively fix it if you achieved it before last night’s shutdown.

Now with mine, every second time I mount my Black Grotto Netherdrake it resets ALL Netherdrake appearance options to default and it is purple again with no fancy tail etc… then I can mount it again 2 mins later and it’s black with my options again… then I can sit there and remount and it resets to purple again lmao.

I was granted this achievement retroactively, dated to 11/07/23, and I wasn’t awarded the new coloration. It’s also kinda weird they call it “Black Scales” when the netherwing drake clearly only has skin (and the Rostrum even says “Skin Color”).

I completed this achievement today and also did not receive the Black Scales appearance for the Grotto Netherwing Drake. Tried relogging, completely exiting the game/battlenet, logging into different characters, disabling all addons, etc. For what it’s worth, I did receive the retroactive mount for the Shadowlands Meta (legacy version) rewarding Zovaal’s Soul Eater on Tuesday’s reset.

Bumping this as I still didn’t get it. I completed the achievement on Tuesday. If the item wasn’t going to be available until Thursday and now I’m locked out of it, it would have been nice to know.

Still don’t this as of post maintenance, and looks like the meta-achievement mounts are still missing as well.

1 Like

Still nothing post maintenance for me, either. Would be nice to get a response acknowledging that Blizz is aware of the issue, because my ticket still has 9 days on it.

Still no fix! I love this company.

1 Like

Still didn’t get my Bestowed mounts and they still are not in the journal after 2 x shutdown maintenances… cmon Blizzard…

Black scales is working for me though much to Setaii’s chagrin.

imgur com/a/ihl8VR2

The scales are fixed, finished the achiev just now, relogged and they are unlocked in the rostrum.

Scales still aren’t showing up for me, but have seen them show up for others. Seems like there’s some sort of bug affecting some people but not others then. Got my achievement on the morning of 3/20/24.