Login Issues

I was in game when the game became extremely buggy. Guild chat was about the only thing working and others reported having issues as well.

I tried to restart the game, and now it won’t get past “Logging into game server”.


I also have this issue. Don’t think its just you

Just tried to login myself and am getting this

Having same issues here.

Having a similar issue. I can get into the game however nothing works I cant even move my guy

Same issue cant log into Stormrage

Same same. not able to log in

same, stuck in dungeon loading screen. - stormrage/FIOS

Area 52 same issue

loading screen gets to about 80% and then stops. had about 4k ping before it booted me.


I have the same issue. Can’t log in, or get past the same “logging into game server” line. Got past once, and game was entirely unresponsive.

Stuck on Dungeon load screen for the past six minutes.

Just got to character select screen. Hopinh for the best

Unless it’s coincidence, i just closed the BattleNet app and restarted it. Now I’m in

1 Like

Same issues here. Icecrown. Update. Got into the loading screen now stopped at about 75%. Just stuck here.
Disconnected WOW51900319

what does everyone have for there ISP?
i got verizon, maybe its a ISP issue.

Okay, logged in with character, stuck in loading screen lol

US Destromath.

I have Frontier fios @above post.

I have Verizon as well.

im blaming verizon.

me also when i try to login its stuck at dungeon loading screen for some time