Level 70 Boost

I can not fly after Enhanced Level 70 Character Boost of my priest in all zones. That includes Dragon Flight. I really don’t want to run everywhere. How do I fix this?

What mounts are you using?



Your character will also receive the Artisan Riding skill and the ability to fly in all flight-enabled zones, except those gated behind an achievement (such as Pathfinder). If you didn’t have any flying mounts, you’ll receive a basic one.


I have tried my flying mounts and my dragon flight dragon mounts and I can not fly with any of them. I have about 15 pluse 70’s and have my pathfinder done and can fly regular mounts in dragon flight.

Did you figure it out, Beaawarrior? I checked your character and you appear to be sitting on your dragon mount with the dynamic flying options on your hotbar. I even tested and you appear able to fly without issue.


Yes I figured it out. I was using the new mount I recieved with my upgrade not realizing it was a dragonflight mount. I was trying to fly that mount like a regular mount. It doesn’t work like that. It’s such a cute mount too. Oh well, I have others I can use. Thanks for checking. It made me go and look again. Yes I can now fly when I use the right mount. By the way, I am an 85 year old great great granny that has played for over 15 years. Love the game. I’m going to use old age as an excuse. Lol.


No worries.

Technically I have flown a dragonriding mount as a normal flying mount, it can happen on lower level characters before learning the dragonriding mode.

Technically they are adding a mode to DR mounts that can switch them into normal flying mounts later also.