Launching BFA Launches Classic/BFA Reinstalling Itself

Not sure what on earth is happening here… I was playing earlier today and everything was running well with no issues. I took about two hours away from the game for work stuff, only using my computer in that time to visit a few trusted websites. When I came back to play again, I pressed the PLAY button for retail WoW, but Classic launched. Tried again, same result. Restarted BNet, same result. So I restarted my computer (it updated while doing so), and when I loaded up BNet, it gave me a 60GB download for retail WoW. Checked my game file folder, and sure enough, teensy amount of data in there.

…What the heck happened? I’m downloading it now, but how do I keep this from happening again? Is there some potential damage to my computer?

3 Likes

Same thing happening to me.

Same here, started up this morning and battle.net appeared to have an update. Then bam! my retail folder has a wowclassic.exe inside it :frowning:
Retail folder is now down to ~3GB

I played a few hours last night then shut everything down as usual, tonight i booted up my laptop to log on and now only Classic will launch and i need to download 56 GB to play Retail.

1 Like

I was playing earlier today and logged off to do something, come back and saw there was an update for wow. Downloaded the very small update less then 100 MB and then it had another download that started right after, this was for 60 GB. I suspected it was downloading the entire game so I checked the install folder, showed 57 GB and I did a scan and repair 3 times now and its taking the download down to 25 GB.

Same thing happening to me. Guess I’ll try re-downloading? Daughter got in okay but she said the “FULL” server we’re on is more or less empty atm and she’s the only one online in guild. Someone messed up bad. :rofl:

Just wanted to chime in.

My battlenet had a minor update which failed. But now its doing a 49gb update.

Was on literally a couple hours ago playing fine but took a break to knock out some season stuff in D3 and eat and now this…ugh.

Also I don’t seem to be getting the prompt for the re-download so I’ll have to do mine manually

Hey all,

Thanks for reporting this, although I’m sorry to hear that it resulted in having to redownload the game files. We are definitely going to be keeping an eye on this to see if it becomes a widespread problem.

It sounds like Battle.net detected some files were corrupt, or the WoW install was damaged somehow. I would double check the install path for WoW, which by default is C:\Program Files(x86)\World of Warcraft.

Make sure the game is not installed in one of the Battle.net folders (for example Battle.net\Battle.net.XXXXX) as those can be deleted automatically when the Battle.net app updates. If the game was installed inside a Battle.net version folder like that it could explain the app having to redownload the game.

You can check the install location in the Battle.net app Settings under Game Install/Update.

1 Like

I love when a blizzard update puts the classic.exe in my retail folder…then the other tiny update completely deletes retail from my computer and I have to reinstall 60gs worth of data…

5 Likes

Same here got a 60 gig update after my small update. With my internet its gonna take about a week. SMH

1 Like

I really think this is a Blizzard problem that requires investigation… we are aware of how to view our direct install path. I am unaffected however my boyfriend’s game did the same thing: Retail unable to launch, Classic launched and the Blizzard Forums are not working for him either.

Can you look into this?

1 Like

Looks like someone accidentally mixed up the install paths between retail and classic so it put classic into the retail folders. Theoretically, a full retail re-install shouldn’t be necessary but that may be the only way to make sure the versions aren’t conflated.

This is not the case.

Maybe you should review this post: You put WowClassic.exe in the retail folder in the last update

This just also happened to me on my laptop. Haven’t used it in about 5 days, loaded battle.net to a wow update. Sure enough, WoWCalssic.Exe is in the retail folder.

I have deleted the exe and am doing a scan a repair now, will report back is this fixes it.

Update: Scan and Repair finished, and re-downloaded WoWClassic.exe to the retail folder again. So its definitely something on Blizzards end, since all the other files still seem to be for retail.

Yep. Same issues here.

Nice game you got here, Blizz.

Ye, I’m in the same sunk boat. Thanks Blizz.

Heya folks!

Thanks for reaching out about this. Oddly, not everybody is running into this problem, so our Battle.net Application team is trying to find out why it’s happening for those of you it’s happening to.

Edited by Blizzard: Previously we asked players to test something where this edit is, but we no longer need this information. The extra test request was removed. Thanks!

Edited by Blizzard2 4/25/2020: Thanks to all the logs sent about this error, we no longer need any. The developers have found what they believe to be the problem and are working on a solution. Thanks for all the help!

When I went to the retail folder there was no wow.exe and only the launcher and wowclassic.exe in both folders if I recall correctly.

Edit - after I restarted and the game files were gone, wowclassic.exe was still in my retail folder. Once I started the download for game data (60.3 gb) it left wowclassic.exe and added wow.exe

Working on the logs…