Krazzlefrazz Outpost Supply Hut

Everything in the quest can be completed save for the supply hut. The laser is faulty and doesn’t do anything. Have abandoned several times, restarted the game, made sure everything was updated and still stuck on this issue since I can’t complete the quest.

3 Likes

^ Same for me.

1 Like

Same issue here.

Went to write this post, came back, and it worked. Maybe there is a reset on the laser gun that I wasn’t seeing? Quest complete.

Same issue. Hopefully by the time I finish cooking my breakfast it will work for me.

Edit: Abandoned quest. Logged out. Made breakfast. Came back and it worked.

Had this issue as well.

1 Like

Yup, same here. Can’t move forward in the war campaign because of this.

1 Like

Srsly wtf I cant progress fix this retarded crap

1 Like

Same here, pls fix blizzard

Same issue here. Abandoned quest, restarted game, and it is still not working. Gonna take a break and see if it’ll work when I come back.

I went away from the area and came back and it worked for me.

2 Likes

I’ve logged out, left the area and closed wow and it’s still bugged :woman_facepalming:t3:

i got it to work by picking up the quest item, then holding it and fly to fallhaven then fly back re pick it up and used it and it worked.

I’ve tried all the above including leaving and coming back the next day, still not working

Bugged out for me, tried abandoning quest then restarting. Tried abandoning and logging out, nothing works for me so far.

Abandon quest, fly to Whitegrove Chapel and back, pick up quest again is what worked for me.

Same here, did not abandon or leave area, just googled it and was reading this Topic here, then I tried to just go around that small hut and try pressing in the center of the screen (Quest Item) eventually worked, made like electric connection between and hut grow up. I would suggest to try different angle and different distance while pressing item. Gl all.
Edit: Keep that hut or small house on focus (left-right click on it) :))

1 Like

I just reproduced this bug. If your weapon is transmogged to the legion artifact, the extra action button does nothing to the small hut. Once I transmogged out of it, it worked fine.

2 Likes

I believe it does have something to do with your weapon, as I unequipped both of mine, retook the quest, and was able to embiggen the hut.

Just encountered this bug myself, didn’t remove any armor didn’t go anywhere just cursed and it worked. Literally just /say (insert profanity of choice here) and like hitting a TV set it worked.