Items Restoration Items Not Found

I could not restore my recently deleted brutal gear and accessories, I deleted them thinking I wouldn’t use, but it’s the case I still need them. This is on my classic WOTLK paladin Hemeraserpal.

Are you still in the same active game session that you deleted them in? If you are, you would need to log out of the game entirely and give it a few minutes for the items to show up. If they don’t?


I tried everything and they didn’t show up, just a crafted ring and a veteran’s belt, both of which I wasn’t looking for.

Normally I would tell you to submit a ticket, but they are pretty clear in the articles and even in the restoration interface that if it isn’t there for player retrieval, then it is gone and there isn’t anything a GM can do. I am sorry.

Something is definitely going on and I’ve submitted my own ticket for my issue. There appears to be some giant gap(s) in the items that are “Loading…” in on the item restoration service.

I’m seeing most of my items from an earlier play session (roughly 2 days ago), then I ran some heroics for about 3 hours…DE’d alot of those drops once I was back in a city. One was accidental that I’d like to restore, but I have 7 pages of just blank items before finally seeing all my recent items from my latest play session.

For the 7 pages of blank items…I can see the removal condition was “disenchanted” but they are all classified as a “consumable” and are just “Loading…” forever. Consumables cannot be disenchanted, so something isn’t working right with the service.

I don’t understamd how I can see 100% of the heroic dungeon loot from an earlier play session, and then inexplicably just see this massive gap. There’s nothing that would classify ALL of that loot from the later play sesssion as things that I “cannot restore”.

Do you still have the disenchanted materials in your bags? I seem to recall that is required when restoring disenchanted items, so I wonder if that could be the cause of the issue.

Yes I do, but that’s not the problem. The issue I’m describing is with the actual Item Restoration site/service. I can’t start the service because my item selection is several pages of just blank items. I wouldn’t know what I’m selecting. Wish I could link my screenshots here that I provided in my ticket which help illustrate what I mean.

They restored my items. Could you guys also retore cloak, neck bracers and boots, they were all Guardian and max tier.

However you were able to restore those items, it does incur a 7-day hardcoded cooldown.

Also - if it is a bug that was impeding the items not showing up, you guys do need to post that over on the Bug Report forum please. There are no GMs or Devs on this forum. Only our SFAs and they are limited in what they can and cannot do.

1 Like