I cannot edit my own forum posts

Hello,

I cannot edit my own forum posts, I used to be able too and now I cannot.

I’m pretty sure that there is now a timeframe where you’re able to edit, but after a certain period of time the option to edit the post is removed.

I’ll see if I can dig up where I saw that.

Edit: I might actually be wrong. So far the one post I found about a similar situation was confirmation that the original poster should be able to edit the post despite how old it is. It was from 2019 though.

I’ll keep digging.

How long ago did you switch from Troll to Blood Elf? How closely does that coincide with when you lost the ability to edit posts made by that character?

good pickup.

the recruitment posts are showing you as a 51 troll?

I think it’s the name change more than anything that’s stopping the edits. OP went from being Frostworkz to Fireworkz.

OP; if you create a new character on the realm with the same exact name as the one posting, you should be able to edit those posts using that character.

Or you can just recreate the post under your new name, if you want them to be done on that particular character.

Not being able to edit and/or losing post count/history is a side effect of the way the new forums work.

they’re different characters, with different post counts

…but when you look at the avatar of Fireworks, it lists the elf as being a troll

That doesn’t necessarily mean it’s not the same character.

When I changed races and names on my paladin, each version of the character has it’s own post count and dates they joined the forums. The avatar on the old version is a zandalari troll but the race and level listed are still blood elf and 120.

Buggy things happen on these forums with name/race changes.

My guess is that the OP changed both name and race and the forums now treat them as separate posting characters.

that was due to the name change.
…which is expected behaviour.

a race change alone, doesn’t usually impact that characters forum profile.

but yes, there could have been some name switcheroo, which would have an impact.

…or all our detective work could be wrong, and it could just be an issue of the posts being unable to be edited due to age :stuck_out_tongue:

A good indication of how they’re not the same character is that Fireworkz, a level 51 mage, posted on January 11. The very next post, made two weeks later on January 24, was made by Frostworkz, level 50 mage.

Shouldn’t be that… I found my oldest post from July 2018 and I can still edit that, I double checked multiple sub forums (CS, General, Guild Recruitment, etc) just to be sure each sub forum doesn’t behave differently.

Possible, but unlikely. One thread was created in August of last year, and the OP was still being edited on Feb 16, the same date as the most recent edit of the OP in the other thread, which was created in December.

If the December post timed out of ‘editability’ on Feb. 16 (approx 60 days), the original post in the other thread would have timed out in October.

So fireworkz forstworkz are different people on different accounts,

I lvled up fireworkz and race changed so that might be it?

It’s possible, but a race change alone doesn’t normally effect the forums. Normally only a name change does that as the posts are tied to the name and realm.

Did the trouble editing old posts start after the race change, or did it work for a while afterwards and start later?

i race changed last week and yesterday was the first time i tried to edit the post.

Looking at the post history on the initial post and the one showing here for you now, something is definitely off. Both have the same join date, but your forum activity here/now is only showing posts starting today.

Have you tried logging out of the forums entirely and then back in? That’s about the only thing I can think of that has a chance of fixing this.

If that doesn’t work, you should definitely report this in the website bug forum.

Unfortunately, that won’t change your lack of ability to edit the old post though. You’d have to recreate the post on this “version” of your character to be able to edit again.

yes i have tried logging out and back in, switching toons and back to the original. Thank you for the help!