Hunt: Winged Soul Eaters

Hunts on OCE Nagrand have been bugged this week they all get stuck at phase 2 and the end boss won’t spawn

22 Likes

just had the same issue on altar of storms. so two bugged hunts now

1 Like

I haven’t seen a wing soul eater anywhere. I have a Sky Chain, but nothing to use it on. Totally confused by this Hunt.

9 Likes

On Proudmoore Shard, stuck on Defeat the Alpha Anima Devourer. Shows the indicator where the NPC should be, but nothing is there. Can pick up chain but nothing to use on.

4 Likes

Just had the same thing happen as well.

Also trying to do The Hunt and the Alpha Anima Devourer won’t spawn for the objectived Winged Soul Eaters

1 Like

this hunt makes 3 weeks in a row each hunt leaving everyone totally confused. i want to see blizzard to please elaborate as to what is happening here. instead im trying to surf the web while dodging bombardments. i really don’t understand why we can’t get any information at all after weeks of issues.

12 Likes

Two of us getting the same. No Winged Soul Eaters anywhere. We have the chain but nothing. This is the 5th hunt in a row that has bugged for me. My partner is stuck on the Ve’nari quest to complete a hunt and has not been able to finish it in 2 weeks due to bugged hunts.

3 Likes

Same here on whisperwind, the damn last guy phase isn’t there just like last weekened with the hunt as well. Two weeks in a row that the second hunt bugs out or doesn’t reset properly after a group kills the final boss. Fix this Issue!

2 Likes

Figured out what is happening…
I went back this morning to try again and the hunt was at the 1st stage. Completed it and the brought down the anima devourer and killed.
That’s when a number of people got credit for the hunt achievement but nobody got credit for the hunt kill. This leaves the hunt in the state of having to kill the anima devourer, but it is already dead.

1 Like

All Hunt quests are completely broken. Can’t advance my Maw questline. Same exact issues as above. Going on 2 weeks now.

6 Likes

This hunt is broken on US-Lothar too. Hooks and chains are there for the final phase but the Alpha is nowhere to be found. The weird thing is it worked just fine when it was up last time but now it appears broken just like the one last week.

US-Durotan is bugged too … ;(

US-Firetree is bugged as well

Confirmed bugged on A52

Yup bugged here as well. Tried turning on war mode, joining groups, leaving zone and coming back multiple times. No luck…

Hope Blizzard fixes this crap soon, if you are going to make an obnoxious rep grind in an annoying waste of time zone, at least have the quests work. One week was annoying enough, now it happens again and no hot fix? Figure it out.

3 Likes

Dalaran-US Hunt: Winged Soul Eaters bugged… second one that’s been unable to progress for no explicable reason. I’m more than a little frustrated by this seeing as they didn’t bother to fix the last one before it changed to the next.

2 Likes

Yup same on Illidan-US

Killed the alpha anima devourer and doesn’t count the kill. Stuck two weeks on stalking the warrens quest.

sadness intensify.