Guild Roster is Empty

Yes, looks like Devs have temporarily taken the guilds and communes completely offline for the time being until they fix it. So pressing J does nothing now.

Same here pressing J does nothing.

Why are you lying?

Same on Kul Tiras

Makes sense. I can see when guildies log in at least, and we use discord as much, if not more than the guild tab. Not a huge deal, if fixed soonish.

Heads up, we’re actively working on this, but it appears that due to this issue there was some data loss within guild channels. Please refer to this post for information on the extent of what data was lost.


Hi, having the same issue on my guild master main, and all alts I have in the guild on US Ravencrest. When I press J all account bound communities are still viewable as normal, but my guild and all character joined communities have disappeared. I still have my guild tag on all my characters though.

Same issue for across all of my characters. All guild/communities are blank as if they aren’t in a guild, but I still see the guild message when I first log in, and can see guild members logging in and off.

Hey folks,

How are we looking now? The devs have tweaked a few things and wanted to see if the changes are showing up on your end.

Edit: Per feedback in this thread, please relog if you haven’t yet, at which point you should pick up the fix. Thanks for all the reports and patience while we resolved this issue!

1 Like

After relogging everything seems to be back to normal.

Relogged, and the guild was back online. Posted in the gmotd for other guildies to do so, as well. Thanks! =D

Can confirm. I relogged and everything is up and working again. Thank you! :heart: :coffee:


I asked my guildmates to assist me in testing this. Relogging has solved the errors for most members. However, some of our members (down in Brazil or in Australia) are still running into issues and cannot see the Guild tab in the Community Panel (J). They have tried relogging and restarting WoW, but it is not solving the issue for these members.

Do you have any other suggestions outside them attempting to run a repair?

Still having guild channel issues on my GM toon on Draenor. I’m having to use the old command /guildroster to see who’s been online or update quote of the day, etc.

Per the request from my ticket. Logan it is everyone in my guild that is having issues removing items from the gbank.

I logged out - it did an update - and I still have the issue - nothing when “J” is pressed - Azgalor

Edit: just checked the guild that I am a GM of on Silvermoon - Same - Nothing when “J” is pressed.

Edit 2: Checked all guild toons on Silvermoon - GM and 1 Officer - Guild/Communites works as it used to. Four other toons - “J” comes up blank as everyone else is noting.

Some of my characters are affected, and some aren’t.

I’m GM of a guild Hordeside on Sisters of Elune, and nothing appears to be wrong. An alliance toon that’s a GM on the same server, can’t interact with her guild at all from the ‘J’ pane. The only indications that she’s even in a guild are the MotD popping up, the guild icon on the taskbar, and she shows the tag if I /who her.

Another couple alliance characters on Cenarion Circle (a realm connected to SoE) can see the guild stuff just fine from the J pane. Both are in the same guild, one is an officer and the other is currently the GM.

Looking into it a little further, it seems that my Alliance characters on Cenarion Circle are unaffected, and the ones on Sisters of Elune are affected, and my Horde characters on Sisters of Elune are unaffected, while the Horde characters on Cenarion Circle appear to be guildless.

CC Alliance, Fine
CC Horde, Broken
SoE Alliance, Broken
SoE Horde, Fine

Edit: Nope, not even that clear-cut. Just checked a 2nd Horde guild on SoE, and they’re borked, too.

No change sadly. Still cannot access anything using “J” on Moonrunner

First of all, if Devs can still log into my account to test bugs (had a few issues during BC release), I am more than happy for them to do so. Permission is given… For the Horde!!

Realm: Dath’Remar and Kaz’goroth
Guild: multiple
guild rank: from guild master to peon
access: full access to none at all
Addons installed: all removed for testing (renamed interface folder as interfacebk)
cache folder: renamed as cachebk, for testing
WTF folder: renamed as WTFbk, for testing

single member guilds (bank toon) appear to be unaffected. I have full access to chat, guild roster, guild bank and tabard shows correctly (yes, i created a tabard for my bank toons)

access in my guild “Death to the Alliance” is either very limited or non existent.
-GM has no access to roster, pressing J does nothing, guild tab missing, can see bank contents (are slow to load though) but cant access the contents, guild tabard is shows correctly.
-various members either have no access (tabard shows and guild bank opens with no ability to access items) or partial access (J still doesnt work but can use /G chat and bank works).

toons in social and raiding guilds, Pressing J doesn’t work, past chat seen (some dating back to 16 Jul), guild tab present, bank access is limited due to guild ranking :slight_smile:

toons not in any guild, pressing J doesnt work, have guild finder tab at the top and a description of what a guild is. the toons in a guild with limited to no access do not have this and the guild tabard correctly shows

Bug could be related to various guilds member roster and their permissions corruption. Perhaps low member or low traffic guilds were not captured during an update?
no chat access, can see bank tabs but cant use the bank (even for GM), no guild control but tabard shows correctly, Guild and communities is missing guild tab but doesn’t act as if the toon is not in a guild.

Good luck to the Devs, hope they can get this fixed soon.

i have had the same issue. only one server seems to be afflicted with the ‘no guild roster’ problem. Mok’nathal. both horde side and alliance side.
so far no effect from the fix. thanks for letting us know this is being worked.