Grid Lines on Ground/Terrain?

I have an M1 Max Mac Studio and performance is great, however I’m constantly seeing white/yellow grid lines on the terrain both before and after the Dragonflight launch.
Have changed multiple graphics settings but with no change. Wondering if anyone has experienced this and found a fix?
Looks to be similar to this issue: White dotted line on terrain


I’ve seen them, too, on occasion. M1 Mac Mini (8core gpu). I’ve found them to be rare and maybe more prominent in certain areas? Which might suggest it’s an issue with the terrain geometry, not so much with the hardware rendering per se.

I see the seams too but, only on external displays. No dotted lines on the built-in display. 16” MacBook M1 Pro 12.6.1. Tried USB-C, HDMI and different resolution monitors. All external displays I tried have the white dotted grid lines. This is on classic Wotlk.

Interesting to know it’s on both retail and classic, maybe it’s an arm64 client issue? Didn’t have this issue on either internal or external display when playing on older Intel MacBook Pro.

I have the same issue (M1Pro chip). Really annoying to see those dotted lines. :frowning:

So, an update from Blizzard Support is that this is a known issue with M1 Macs, and is ‘being investigated’. No fix available until patched, unfortunately.

1 Like

Just to pile on this is a problem with the M2 as well. I’m playing WoW on an M2 Macbook Air and while I get really great performance, I see the dotted lines sometimes.

I have this problem as well with our without addons. I’m running a micro pc with an AMD Ryzen 7 and onboard Radeon graphics and 64 gig DDR4 memory. It’s not just Macs, it’s some PCs too. It’s not on every character even in the same zone, but it’s making the game unplayable since I can’t use my map.

this is working as intended i think. its just the way graphics render on mac. never not seen it

I don’t think it’s working as intended, but I don’t think it’s an even remotely priority issue. It’s mostly easy to ignore and doesn’t block gameplay in any way and it’s mostly just a mac issue and all of those things are super low priority to any studio that has a million other things on plate.


It does serve one purpose, though: even though I dropped a sizable wad of cash on an M2 Ultra Studio and Studio Display, I can still experience an issue I had on an first-generation Intel 27-inch 5K Retina iMac ten years ago. Only a fool would complain, though. Everything else about this system is, simply put, terrific.

Started seeing this as of 10.2.6