FPS Freeze Problem and How Blizzard (didn't) Solve it

After a 1 year break from WoW I came back to play and my first issue was FPS freezing in some situations. It happened to me 3 years ago when I came back to playing as well, so I thought it’s common to have this kind of problems when new updates are available to play. But there was huge difference in support solutions. 3 years ago I was asked to add Additional Command Line Argument to force DirectX11 and it completely solved my problem first day. This time I opened a ticket, described my problem (thought it’s only in instances), and suggested that maybe the solution could be the same. I was ignored, we went thru some procedures and it took like 2 weeks of ticketing… we went thru all updates, drivers, turning off ads, reseting UI, everything. Blizzard even called me and very nice GM spent with me 2 hours on phone doing everything again. Nothing worked.

As I tried to play I figured out that the problem appears whenever Hunter comes around me and use some abilities. So I told about it in the ticket. In my opinion it was great hint! Firstly, I got ignored with this one. When I started to be almost sure that’s the problem I got Answer of the Year from one GM: “There is no problem on our side, I play hunter and I don’t have any problem”. Cool… am I in some kind of hidden camera experiment? Obviously I have problem, not GM… like… come on!

So I spent one more week on testing different circumstances and finally I got sure it’s Hunter related problem. I found one who was keen to help with testing and we went thru all abilities in duels. Finally I could confirm that in 100%. Two abilities which were causing the problem were: Bestial Wrath and Resonating Arrow. So it seems someone coded them wrong, without any optimalization. But hey, I shouldn’t be the only one having this problem, correct? Yes - correct. I used google and I figured out that it happens to plenty of people before! So Blizzard should be aware of that.

Luckily for me in one of the posts some player answered that his friend just forced using DirectX11 instead of DirectX11Legacy by Additional Command Line Argument and that solved all problems. I tried it and it worked. Easy? Easy. That was first solution I asked to check when opening the ticket.

I am totally disappointed, as it took 3 weeks of harsh gameplay to NOT solve the problem. I am wondering if all good support technicians were fired or left the company? And students were hired to cut the costs?

1 Like

You were asked to …

Here are the instructions:

  1. Press Windows Key + R.
  2. Type DxDiag and press Enter.
  3. In the DxDiag window, click Save All Information.
  4. Name the file “dxdiag” and click Save
  5. Once you have that made, open the file. You’ll need to copy and paste the contents of the Text document into the post, and put four Tilde (~) marks above the DXDiag. It’ll look like this:
DXDiag goes here

If you have issues pasting here, please use Pastebin and post the link (ex: Pastebin (dot) com/123456).

Thanks for providing the data.

1 Like

I’ve done it for 3 weeks. To every single message. Didn’t work. So I found the solution which I suggested to support. Got ignored, tested it myself. Added the solution for others. Thanks for your contribution.

1 Like

So you provided the information to a GM in a ticket, because I see non in your posts.
You computer meets or exceeds the minimum system requirements for World of Warcraft?

Glad you got it fixed.
Have fun.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.