Error code wow 51900319

I keep getting error code WOW51900328 after 2 hours of trying on Everything recommended by Blizzard unhelpful chatbot. Please refund the subscription back to me based on the downtime. Thanks.

Same here error code 51900328, only able to connect with a VPN.

1 Like

Encountered same error for the past 2 hours. Able to login now.

Error msg: #WOW51900328
Provider: Singtel

At least one of us were able to sneak in haha.
Still unable to log in.
Just now was able to go to the character selection page but was disconnected back to the main page while loading up.
Now back to trying again to get past the error code.

Getting the same error as everyone else.

Location: Singapore
Server: Frostmourne
ISP: Singtel

Connecting through VPN seems to help

Yep, code WOW51900328. Looks like it affects most areas north of Australia.

Location: Jakarta, Indonesia
Server: Barthilas
ISP: First Media

1 Like

328 issue.

Singapore Singtel
Server: Bathilas

Mine Indihome, got same problem

WOW51900328

Game: Burning Crusade Classic
Location: Singapore
Server: Arugal
ISP: Singtel

Managed to login with a 21k ping. Got disconnected and couldn’t re-connect.

Doesn’t seem to unique to Singapore.

Just use a VPN for gaming guys if you have one. I’m logged in now. Blizzard will take ages to fix this as usual.

Managed to login after 5-6 tries but spiking up to 20k ping too. I’ve also heard that some of my friends from Malaysia couldn’t login too.

Location: Singapore
ISP: Singtel
Server: Nagrand

From Singapore, also can’t login.

seeing very high latency… restart computer/modem and can’t login thereafter.
from Sg, using starhub.

1 Like

Yeah same, managed to login one time but with a very high latency.

Location: Jakarta, Indonesia
Server: Frostmourne
ISP: First Media

Not working for me either!

Location: Bangkok ,Thailand
Server: Frostmourne
ISP: True

6 accounts, 5 different computers - Sunday morning family game time ruined!

Also in SIngapore, also not working :frowning:
Tried my cable as well as mobile phone tether

Singapore, M1
Unable to log in for WOW Shadowland (error code 51900328) since this morning
Wow Classic is ok

Using VPN( to the Singapore region) allows me to play.

I exaclty got same issues,…

Location: Indonesia
ISP: Indihome
Server: Remolus A

same issues… bump!

Location: Singapore
ISP: whizcomms
Server: Barthilas