End of the Dream quest disconnection from server

If I attempt to do the cinematic part of the quest ‘End of the Dream’ in Ardenweald, I get disconnected from the game once the cinematic ends. I cannot complete the quest. I am awaiting a ticket response to fix this issue.


Same thing is happening to me I get flicked out and it tries to load legion and disconnects very frustrating as I can’t go no further until I can finish this one grrrrr

Same here. Attempting to load into the corrupted Ysera scenario results in WOW51900319 error code. Cannot progress with the Ardenweald campaign with this bug. Going to bed…

Same is happening to my girlfriend. We are in the same house, quest worked for me, only difference is I have ethernet and she doesn’t. let me know if you found a fix.

Found the problem…apparently you must be lvl 58 to complete the quest.

Has anyone been able to test the level 58 thing? I’m currently having the same issue with this quest; I’m only lvl 35, so Baysogrimm’s reply stands to reason. Has Blizzard confirmed this yet via ticket reply?

So, I was able to complete the quest just now at lvl 35. I just mashed esc on the cinema to quit it as soon as possible, had a battleground queue pop as soon as I ended up flying on the dragon, and had gone around the southern zones (lvl 60 areas) in Ardenweald. Hopefully this helps someone else even though that’s pretty random.

1 Like

So I managed to complete this eventually. The only thing I did differently was to restart my PC. So I loaded up and the next day it just…worked. I have literally no idea what changed xD

I’m having the same problem here, already tried skipping the cinematic, using a diff PC, restarting, but as soon as Ysera shows up on my screen i get disconnected.

I had the issue, and simply disabled all addons and it worked first try then.


Same thing is happening to me. Can’t get into the instanced dragon mode after the cinematic. Level 60 Demon Hunter. I simply keep getting disconnected over and over.


i got this exact problem today
fixed by restarting pc

Got this problem, got generic response on my ticket, that is sad.

Receiving the same crash/disconnect for End of the Dream quest.

[Work Around Fix] So I was able to get around the disconnect by

  1. Exiting out of the cinematic
  2. Immediately logging out before the Legion load screen pops up
  3. Logged back in and the Legion load started and completed

I wonder if going back to Stormwind and activating the Legion timeline by talking to Chromie might fix this? I did go to Chromie and change the timeline to Legion and skipped the intro Legion quest, but then I changed it back to Shadowlands. Maybe I will try on my next playthrough…

1 Like

I ran into the same thing. I wonder if this is because I chose Legion timewalking, but didn’t complete it and skipped over to Shadowlands without returning to current timeline at Chromie. I tried completing the Val’Sharah questline to fix this, it didn’t work. The words assault on the temple to show up after the Legion load screen, then disconnect. Brandolorian’s work around is effective, but you need to get the timing right.

1 Like

I had the same problem. I was running the Addon TRP. Disabling it did fix it for me. I did get caught in a few longer than normal loading screens, so this quest is clearly chugging. I did this on a lvl 40 hunter, so the level cap no longer applies.

If you’re running addons and not able to load this quest, try disabling them.


Thanks for the info - followed your advice to the letter but I was still taken to the Legion loading screen upon re-login and disconnected as soon as it completed :frowning:

Even tried quitting after logging out and before I could quit, I was disconnected.

As of Dec 14, 2023, disabling all addons worked for me

I was able to get it to work by enabling Advanced Combat Logging in the Network settings. This is as a level 30 in Shadowlands timewalking.