Enchanting - Weapon Enchants on to Vellum

When attempting to place a weapon enchant onto Enchanting Vellum, I receive the error: “That spell is incompatible with your weapon appearance” and fails to enchant.

I’m a hunter with a bow equipped. The game is taking into consideration my equipped item rather than the target item in the crafting panel when doing a weapon enchant. Unequipping the bow resolves this and Enchanting Vellum can then be used.


Confirming this bug report. When trying to enchant ‘Sophic Devotion’ it gives the same error noted above. Taking my transmog off of my bow, or switching to a default model weapon, fixes the issue.

1 Like

Bump. This bug still persists as of February 2nd. I just equipped a melee weapon to get around the problem but it’s just silly…

(removed because it seems unrelated)

Still not able to put Weapon Enchant on Vellum. Why is this still a problem? It was reported weeks ago.

1 Like

I came to report this same thing. It doesn’t matter if you’re trying to enchant someone else’s weapon or a vellum, if you have a bow equipped on your character, the enchant fails. I had to unequip my bow to finally be able to enchant my guildie’s staff weapon.

It doesn’t seem to be consistent because I know I’ve been able to enchant other peoples’ weapons without unequipping my bow, or enchant vellums.

This also only applies to weapon enchants. I can enchant all the rings and cloaks in the universe with my bow equipped. As soon as someone wants their weapon enchanted from me, my bow becomes a problem.

Verified. This is such crap.

Bow has to be unequipped.

This is such crap.

Can I get a refund? I am through with this sh!t.

This bug has been around since sometime in Shadowlands.

I guess I was lucky to have a small stock of Celestial Guidance enchants in my g-bank for my multiple alts on two accounts. Why can I no longer enchant vellum? This puts unnecessary limits on all my alts that cannot “afford” to buy the service. Why was this changed? Or is it just another long-standing, not-addressed or not-fixed BUG? Edit after response from GM: The creation of Enchanting Vellums is temporarily disabled
No clue how long it’ll take and apparently it was due to some “unexpected use” (cheating or botting) issue? Anyone know?

1 Like

Same issue…wtf

It is now 5 Dec, almost a YEAR of this bug, and I cannot enchant vellum with Sophic Devotion without unequipping my bow