Elysian Decree Macro "You are in the wrong zone"

Elysian Decree is acting like its still a cov ability for macros, any idea how to fix?

3 Likes

Just remove it from your bars and grab it again from your spellbook while you are in Dragon Isles. You probably didn’t change it on your bars since Shadowlands, so it’s still the “old” cov ability and not the “new” one.

Oh and if it’s a macro thing, make sure to also delete that ability from macro and do a shift click on it in the spellbook to bring it back into the macro.

got the same issue, precise sigil talent is the root of the problem.

Elysian Decree (Talent) does not have a precise sigil altered version, so system uses our convent ability instead…

Easy fix, Blz please…

3 Likes

Bump, please fix this blizzard, I have to take concentrated sigils just to make this work. :frowning:

3 Likes

This is such a stupid oversight too, how did this get through beta testing?

Until this is fixed it’s impossible to make macros with this ability.

1 Like

Just remove kyrian at the end of the macro then itll be fixed

When you hover your mouse will say if is a “class” skill or something else like “covenant” skill incant really remember.
Is because they were treated different. Make sure you drag and drop from your spellbook

Been having same issue. Mainly trying to use a “#Showtooltip /cast [@cursor] Elysian Decree”

Having the issue with other sigils too. Been using same macro for years and with DF it’s no longer working for sigils.

1 Like

dont play DH and dont know if this will work but… rewrite the macro and shift click the ability from your spell book to the macro string and see if that works. the coding may be different.

Drag and drop from spellbook unfortunately does not work ty for the suggestions though guys. Still unresolved.

The precise sigils/Concentrated sigils talent is what screws up Elysian Decree for me in Havoc. I remove that talent and Elysian Decree works fine in macros.

2 Likes

This seems to be the exact problem, which is weird, cause I thought it worked for me up until tonight when I went thru changing to raid talents. I went to change back after raid and now the Elysian decree icon/tooltip says “You are in the wrong zone” please update/fix

Found a fix for the issue. Are you all using a macro addon ?

it didnt, was reported day 1 of beta :slight_smile:

the easiest fix is to swap covenant

Sorry for necro’ing this post, but I can’t find a fix to my elysian decree macro not working. It was working fine when I initially made the macro but switched to havoc and back to vengeance and it’s now grayed out, saying “You are in the wrong zone!” Surely, Blizzard’s incompetence hasn’t been going on this long with this particular bug, right?!?

You need to use the proper spell ID, iirc. There is still a shadowlands Decree spell ID in the game. Can’t remember exactly what my solution was but I had this problem last year too.

Unfortunately can’t find the spell ID anywhere on the internet, tried last night, it doesn’t exist. On a side note, now none of my sigil macro’s are working, couldn’t just a single one of them in a game of WSG that I just played.

390163, though I don’t know how this actually helps you. I don’t think you can use a macro to cast by spellid.

I’m going to test in a bit, but I’m sure a workaround is to simply swap covenants so when you switch to havoc, you don’t gain the wrong elysian decree.

Problem is I’m not Kyrian, I’m Night Fae, so there’s literally no reason that my macro shouldn’t work.

#showtooltip
/cast [mod:shift,@arena2,harm] [mod:ctrl,@arena3,harm] [@arena1,harm][@mouseover,harm,nodead] [] Elysian Decree

This issue is related to macros for talents that override action bar abilities. In this case, precise sigils. For some reason, the macro is pulling the covenant ability override. Which is weird, since for concentrated sigils, both overrides for elysian decree are tagged as kyrian covenant abilities yet it doesn’t have this problem.

I wasn’t able to replicate it onto all sigils, though its definitely the same category of problem. I know that spiritbloom with font of magic used to have a similar issue if you had it as devastation but not when you switched to preservation, causing the macro to pull the rank 4 spellid override instead of the base spell at rank 3.

IDK of a way to actually fix this problem short of dropping precise sigils.