Critical WoW bug with AMD drivers

The crashes have greatly reduced for me, however they still occur sadly. I had 2 crashes this week. One was in a timewalking dungeon, the other was on Sarkareth

I have a 6600XT with the latest drivers as well as DX 12 and my problem is staying in game, its almost as if the login verification server isn’t stable and I keep getting kicked out of game to the login screen, also the game tab has been logging out and logging back in.

Unfortunately the only thing u can do now until AMD admits there’s an issue and fix it is forcing WoW to run on DX11. You’ll have a performance impact in DF though

Can confirm that these listed solutions only worked for a few days before seeing more crashes again. Dx 11 is the only true solution so far.

1 Like

I have been getting this a lot… especially in caves in dragon isles, the game will freeze, then black screen, then back to the game as normal. But then sometimes, it doesn’t go back to normal, instead it keeps repeating the same over and over again until the game crashes. I have the latest drivers, I will try forcing wow to run DX11.

Edit: Using DX11 solved the problem for me, played 2 hours without the issue happening which is rare so I’m pretty happy now. Hopefully it lasts.

1 Like

Just wanted to chime in and say it’s happening to me too. Pretty much same specs.
7900xtx gpu
7800x3d cpu
64GB ram
Does not seem to happen on retail, only on wotlk classic. Happens multiple times whenever going into a dungeon. Also noticed my gpu starts increasing fan speed like crazy which is weird b/c I would think a 15 yo game wouldn’t have an issue on a ~$3k modern pc. Trying dx11 seems to make it better but blizzard or amd really needs to address this, it’s kind of ridiculous - I can play pretty much anything I want but wow classic of all things makes my pc scream.

1 Like

Sapphire Nitro 7900xtx gpu with 31.0.22011.4008 driver at present (was having issues with older too)
7800 x3d cpu
msi mpg x670e carbon mobo

I was having weird flickering lighting issues in the open world particularly from about 8pm australian time. Force turning off the CPU’s igpu in the motherboard’s bios solved that.

I still get the occasional black screen for a couple of seconds & then coming back, potentially with some odd graphics after (e.g. flat white sections on the animated character face in the player pane). Odds of this happening may possibly be higher if I have video running on the second screen in browser (browser hardware acceleration turned off).

Issues were nightly with the igpu on & it’s very irregular since i turned off the igpu, haven’t had a problem in instances. At present I’m staying with DX12 but it’s nice to know there’s an option if it starts happening in raid.

I had a RX 7600 that was repeatedly giving me these issues. It was particularly awful in dungeons; it was rare to do one without getting at least one freeze/black screen with whirling circle/eventual return to game. It happened many times over a day and nothing I did fixed it.

Two weeks ago I returned it to the supplier and reinstalled my old Radeon card (which is itself a bit wonky but in different ways) and since putting that card back in I have not had one single repeat of this situation.

I believe there is something relating to the RX7 series (whether it be the cards themselves or the driver series) that is having some sort of clash with aspects of WoW. I have decided to buy a Nvidia (although even those cards are currently having certain gaming issues, and Im waiting to see if those are corrected). I can’t afford a more expensive Radeon that is not part of the problematic series and I am not prepared to buy another one until the issue is corrected.

Get DDU and the AMD clean up programs use the AMD Clean up first once it has removed all of the old driver it will ask you to restart do not do the restart yet run DDU and then restart I say this because the AMD Cleanup tool doesn’t always get everything once DDU is done your pc/laptop will restart this has to be done in safe mode to work once your pc has rebooted then and only then do the install of the new or newest drivers from AMD

Half of the time it is not the card it would be windows overwriting the new drivers from AMD with legacy drivers from Microsoft I also have the radeon RX 7600 XT and was having this very same problem and found out that Microsoft is doing this and to stop that you would have to turn off the automatic download of drivers from Microsft

So I’ve been having this exact driver timeout and crash issue with wow and wow only. 6800xt ryzen 9 3900xt, every other game no issues

Im having a similar issue with WoW when running PTr 10.2 version. My game Just closes out of nowhere with no error msg whatsoever. No issue at all on retail 10.1.7 until now, that is already on 10.2 version, though not yet available to play, but already started do close by itself on menu screen.

I got a 6900xt with 7800x3d cpu.

No issues on my laptop that has Intel/Nvidia setup.

Game doesn’t allow me to run on DirectX 12, and even on Dx11 still closes by itself. At first I thought it was a issue with ptr, but now it has come to retail as well, after 10.2 update.

There is indeed a compatibility problem with Blizz and AMD. Too many ppl having problems.

1 Like

Same here. 10.1.7, no problems. 10.2 late PTR or today after patching, have a lot of trouble getting through to the menu. I just found that if I alt tab away from the frozen client, it eventually got to the menu. I am…concerned.

Didnt have a problem with 10.1.7. Had this problem with the 10.2 PTR, was able to uninstall and reinstall but then after opening it a time or two it would not launch anymore. Now with 10.2 out, it is happening to where I can’t launch the game, works if I go to dx11 but curious that it worked previous to 10.2.

Same thing, I managed to play a bit on ptr 10.2 with Dx11, but it would close the game randomly quite often. Quite annoying

Now it is happening on retail, sigh

A curious fact is that whenever M+/raid was not available on ptr for testing, this issue didn’t happen.

I’ll chime in here with my experiences.
I’m a long-time user of MSI (AMD Chipset) graphics cards.

Back when the XT cards where first being put out, I started having issues with WoW.
I literally smoked 2 RX 6900 XT Trio cards before I realized the issue.

What I discovered with the assistance of MSI and AMD support was the GPU’s can’t take the heat that is produced from WoW if you’re trying to play WoW with anything other than minimal settings.

And they have never improved the heat issue with any subsequent GPU’s in the Trio cards.

I have literally considered returning to dual cards in crossfire so I can return to playing WoW with all my sliders max’d as well as all the rest of the bells and whistle features.

You’ll need to monitor your GPU’s temp as it will hit 100+ Celsius easily with sliders and features set to higher settings. Even toning everything down, Spell graphics will cause the GPU to temp spike and crash.

The only fix that was implemented over the course of all the beginning issues was they wrote a force shutdown into the GPU to cause an entire system shutdown so that the GPU would not smoke itself. Thus, causing them flooded with RMA’s from folks smoking their cards. Like I did with two.

All I can say is turn your sliders and features down. And watch your GUP temp.

Now I rarely Temp spike in dungeons and raids. But I will sometimes need to turn away from the spell focus as I watch the temp climb and hit 100 Celsius.

Can often be problematic in outdoor areas when you have a large gathering of both faction folks for a World Boss or other public event.

Just my two coppers on what I have discovered in my travels with current MSI AMD chipset higher end cards.

1 Like

I keep MSI afterburner overlay when playing and temps never rise above 60°c even with setting maxout, on both cpu and gpu, don’t think temp is the issue in this case

Yeah i’ve monitored temp closely. I don’t usually go above 60-70 degrees with GPU while playing WoW or any game. I have 7900 XTX


I am locking this thread. This issue is not the same as the original poster issue. This is new for 10.2. I do recommend posting in this thread and try launching the game in DirectX11 following the steps Here. NOTE: While using DirectX11, some graphics features may not be available in the game, and performance might be a little worse than normal. I also recommend turning on Graphics Quality down to compensate for any performance issues until this issue can be resolved.

Thank you.

1 Like