Crashing upon login but only on timerunning

Yo! I’ve been having fun with timerunning, but every time I try to log into a timerunning character, my game freezes. If I try to log into my rogue (also timerunning), the game just crashes. I can log into any normal character without an issue, its only the timerunning characters. Anyone else having a similar issue?

Update: It is now only my rogue that has issues. Is this something to do with logging out in the Dread Wastes?

Another update: I figured out what the issue was! The game tries to load too many people at once when I log in, so I have to log out in places that don’t have a lot of people and then I’m fine.


i get freeze randomly in remix nobody wouldnt respond to my post about it

Oof. Sucks to suck for us I guess lol

So weird, I’m experiencing the same issue. Panda remix rogue, freezing upon login. It’s happened at a couple different places, not Dread Wastes, fyi.

EDIT: I disabled a few addons – most notably All The Things, because that thing is massive and causes bad stuttering at login normally anyway – and the issue was resolved.

EDIT 2: And now it’s happening again. No idea what’s going on.

1 Like

Same thing here, I can log into any retail character but my game crashes when I try to log on to one of my MoP ones.

Came here to check. Yep, I have this issue too.

I tried ATT and that didn’t fix it. It is definitely an addon though, after testing just now. Just a matter of figuring out which one. The annoying thing is you have to close the game and relaunch it each time to check.

Apparently I just had to try logging in enough time and it works now??? This is so stupid, what on earth is happening LOL

It’s a combination of addons, I just don’t know which ones. I thought I had it narrowed down cause I enabled a few and the crash started again, but disabling everything else but the 4 I enabled made it go away.

If it was an addon, I think it would be a consistent issue, and it would screw up at least one of my other characters. The game is once again crashing for this one specific character.

nah, my game keep crashing even after i deleted the addons

I think I narrowed it down to Handy Notes; Dragon Isles.

No idea if disabling it is a perma fix, but it seems to work so far.

Same, I go through the loading screen and instantly when the game displays the first frame of the actual in game world the client freezes up. I’ve left it for as long as 15 minutes before having it actually recover and become playable.

Disabling all addons lowered the duration of this lock up to a MERE 13 minutes or so.

Even with everything disabled it’s not solved.

One thing I’ve noticed, every time the client finally recovers and becomes playable, the first thing that happens is I get the Tutorial Tooltip explaining my cloak buff popping up, this tooltip was never popping up on every login before this issue started.

Since someone above mentioned their location in Dread Wastes, I would like to note my character logged out on a random hill in Valley of the Four Winds is fine, my characters logged out in Pearlfin Jinyu Village and Shrine of the Seven Stars are broken

I don’t think I even have that installed, so that’s not it for me.

Yeah, that was me. My character in the shrine is also really hard to get into. I guess the consensus here is to log out in random places so it doesn’t break?

1 Like

I’ve been unable to log into my remix for days and turned off all my addons. I’ve had the character moved via the stuck character service. I can play everyone else fine.

Did you try turning your graphics all the way down as well? That’s what I had to do. Also where did you log out? Was it somewhere with a lot of people like the shrine?

If you have any transmog addons like MogIt, that’s what is causing the issue

1 Like

Disabling MogIt fixed it for me

Maybe I’m crazy but perhaps the fact that so many people are having this issue on the same game mode, Blizzard should say something and perhaps work to fix it. Because I resubbed to try and its literally unplayable for me. I can’t login with a fresh toon on remix. This is bad. They have the resources, they should fix it. I highly doubt it’s our fault when so many of us have the same problem.

1 Like

I have to disable all my addons if I want to log into my timerunner. Once I’m in, I can turn them on and reload. Then I can play normally.

1 Like

I’ve found that this is an issue only on my higher level toons. Can’t login to lvl 60 dk but could login to 10-35 lvl pally, but now i’m 43 and experiencing the issue again.

edit: disabling like 4 addons fixed issue for now?