(Classic) Move Anything Equivalent

It seems good old Move Anything isn’t available for Classic from what I’m seeing.

Any good suggestions for a simple equivalent? Mostly just need it to unlock my character portrait and the portrait of my target.

3 Likes

The character/target frame can already be unlocked with the default UI
As for alternatives, there is BlizzMove but that isn’t updated for Classic either

1 Like

Yeah… what about parties?

Under Interface options go to Raid Profiles and check “Use Raid-Style Party Frames”. You can now move your party frames by unlocking them using the little arrow on the left of the screen.

3 Likes

For easier symmetrical portraits may I suggestion my own creation: Focused – www.wowinterface.com/downloads/info25191-Focused.html

6 Likes

Just wrap your links in code tags
https://www.wowinterface.com/downloads/info25191-Focused.html

1 Like

Thank you, kind sir.

Whelp…something’s fubared…if I tell Leatrix Plus not to manage frames and then unlock and move I get this:

Date: 2019-09-07 03:19:55
ID: 1
Error occured in: Global
Count: 1
Message: ..\FrameXML\PlayerFrame.lua line 634:
   Frame PlayerFrame is not movable
Debug:
   [C]: ?
   [C]: StartMoving()
   ..\FrameXML\PlayerFrame.lua:634:
      ..\FrameXML\PlayerFrame.lua:633
1 Like

you can’t actually move your unit frames, it lets me unlock, i can’t move them anywhere though

1 Like

I can just fine.

OP: yeah I came here looking for MoveAnything answers too. Really want to move tooltip, quest log, well everything actually.

Grab ElvUI then.
https://www.tukui.org/classic-addons.php?id=2

People need to stop suggesting ElvUI for everything. Really annoying. Not everyone wants to use that monstrosity.

I have been using MoveAnything with classic without many issues from this link:

https://www.curseforge.com/wow/addons/move-anything/files

Comment out line 891 and 892 in MoveAnything.xml for less script errors.

You will still get some errors, but the functionality is still there and working for the most part.

20 Likes

ElvUI is a suggestion, just like suggesting a broken, no longer supported, tweeked and still broken, open to further breakages in the future if left unsupported addon.

People get to try if they want to and take their pick if they find something workable for them.

7 Likes

I had the exact same problem in Classic, using LeatrixPlus. Drove me crazy to the point where I disabled all addons, moved my player and target frames, then started turning them back on, one-by-one. Had to do it a couple of times, because something in LP kept causing them to jump to the middle of the screen.

Finally though (3rd try? 4th?), it finally stuck. Either I undid a checkbox, or I turned everything on in just the right order. Sorry, I know that’s not what you’re looking for, but just wanted to say it can be done.

Hey, maybe you could help me out here. Every time i try to download this addon from curse they will ask to open up twitch, i agree and then twitch opens and it doesn’t download…am i doing something wrong?

My suggestion is to totally delete the Twitch client from your pc. It’s bloated and very poorly written.

Just do a manual install: Click the “Download” button instead of the “Install” button, then extract the .zip into your World of Warcraft/_retail_/Interface/AddOns folder to install the addon manually.

I ended up writing my own small command line updater to do this. It can update from multiple addon websites for both classic and retail. It doesn’t stay running all the time, it runs on demand or by using the Task Scheduler. While my computer is sleeping it will update everything then automatically close and put it back to sleep when it’s done. I never suffer from all the bugs that seem plague Twitch users.

Usually I do not share my personal apps publicly, but in this case if anyone really wants it, send me a mail in-game and I will share it individually.

1 Like

Wog! I can’t figure out how to message you. Could you please message me and send that file? I would be so thankful!

Send me a message at admin@8v.to and ill send it over, still working like a charm a year later :slight_smile:

This worked thank you.

Hi! Know the thread’s pretty old but with pre patch around the corner think you’d be able to make a working MoveAnything for 3.3.5? :smiley: Thanks!!