Can't launch App - DLL error

The Down load worked for me…

Dumb question, but having run into this error when I opened up my computer this morning, and having figured out how to download a new version of, I’m still left without a desktop icon to click to actually start Anyone know how to get that back? Copying the “warcraft launcher” from my World of Warcraft folder and trying to use that gets me another error message with a " BLZBNTAGT00000AF0." Which link is exactly zero help.

I had this issue yesterday. Uninstalled and reinstalled as directed and fixed the problem. This morning it prompted me once again to update and did the exact same thing again. This is tiresome Blizzard. Obviously something wrong with this update, not something on our end, so please get it fixed as I refuse to have to reinstall daily.


IDK about the Bnet launcher etc but the WoW servers have been horrendous this past week. I can play Starcraft 2 totally fine but WoW has ~350ms latency/ping issue

Are we going to have to reinstall battlenet everytime we log in now? Because I reinstalled last night and played and now its telling me that the DLL is missing again this morning?

I got this message as well, this a.m. when I tried to login and play.

Tried to log in this morning and it told me I was missing a dll as well. I played last night without a problem.

Evidently there this is a known issue. BlizzardCS tweeted this reponse.

1 Like

Having The Same Problem. Literally was fine last night. hell i logged off and and shut down my computer and have not been on it till i tried logging on just now. hopefully they can fix this without having to re-download stuff.

Thank you all for taking the time to report this issue! The development team is aware of the problem and we are tracking it at the following thread:

We will post updates as they become available. Thank you for your patience.

1 Like

I had the same problem as everyone else.

I just uninstalled and reinstalled and now it’s working just fine.

Same problem. No uninstall but just downloading bnet client again worked

what a way to wake up to St Paddy’s Day…

1 Like

I have same issue " A required DLL could not be found. Please downaload and re install"

Every time I re-install it works. But next day I get the same error.

I have deleted the Battlenet folder.
I have done a /sfc scannow to fix window issues and a verification of windows.

Got into your folder. Right click “ Launcher” and go down the menu to “send to” then select “Send to Desktop (create a shortcut).”

1 Like

Thanks so much! I was drawing a complete blank!

Just FYI, even after downloading and re-installing, I had this error come up 2 times. Each time I would just relaunch the setup file and it would be okay for a few hours. After a few hours it would tell me I had a update, and I would update, and after it relaunched, is when the DLL error came up. I did this 2 or 3 times, and it finally updated without any error (so far so good, but definitely seems like it could be a recurring issue).

Razgare - Thank you for taking the time to post! The underlying issue has been resolved, but may not be retroactive. However, the instructions below should fix it permanently:

1 Like

It appears to be working correctly for me now. New update came through just now and it’s a new version of the previous version…everything looks normal right now.

I don’t know how to talk about these technicalities properly. Anyway, it does seem like the issue is finally fixed for now. At least on my end.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.