Cannot complete quest Fight and Flight (after hotfix)

Quest name: Fight and Flight
Issue: The quest is part of this week’s Kyrian campaign. My character cannot complete the quest objective, i.e. fly with Xandria, because she does not interact with me.

Video showing me accepting the quest:
How other people did the quest (on beta I believe):

I think my problem is related to one issue addressed in today’s hotfix,

Fixed an issue where players could not get back to the Zerekriss to accept the Kyrian Campaign quest “Fight and Flight” if they left the area.

While Xandria was carrying me to Zerekriss the first time, I did accept a summon from my group to do some activity in another zone. So I abandoned the campaign quest I was on, and thought I could go back and do it later.

When I came back to Maldraxxus, the yellow quest marker was on Zerekriss with quest Fight and Flight. I found Xandria near the flight point, who gladly flew me over there. Next is shown in my video linked above, that I cannot fly with her to complete the quest.


Same issue here, also opened a ticket and got a generic response. No amount of resetting has helped, I even tried a fresh install of wow on my work laptop with no addons or anything, same thing. Dropped and reacquired the quest in every way imaginable. It’s completely bugged.

1 Like

I’m getting the same issue. Flew down with her the first time, then BG popped. Came back to no quest npc so I abandoned and reaccepted. For some reason i cannot fly with her again. Tried every which way of resetting the quest as well(Abandoned, no addons, all addons, relog, reset).

Submitted a ticket, got the automated response so I resubmitted. Average response time 11 days. Lets hope it doesn’t take that long.


Yeah, I was summoned to a dungeon during mine, it seems like all of us were summoned during the quest and that broke it. Dropping it and picking it back up doesn’t change anything, it’s like the quest progress doesn’t reset even if you drop it.

Same here, after accepting BG it’s not letting me interact with Xandria anymore. Hopefully, it will get fixed soon.


Queued for a dungeon and came back. Couldn’t click on Xandria. Abandoning quest or going back down to the FP not working either.

Same bug here, Got in a BG, NPC was gone when I came back
Accepted the quest back in Zerekriss but Xandria won’t pick me up to fly back to the other quest part

1 Like

Same. Been stuck trying to reset and abandon and all that for the entire day. I can’t get xandria to talk to me and take me where I gotta be

1 Like

Also currently having this issue after doing a BG.

Same issue. I’d started the quest, Xandria was flying me out of the pyramid when BG queue popped, after landing I accepted. After leaving the BG, she wasn’t where we’d landed to start the next part of the quest(objective was to speak to her), so I dropped the quest, went back to the flight point where she sits to fly you up to Zerekriss, went up there, accepted the quest, and now she won’t interact.
I’ve tried dropping and picking up the quest, logging out, exiting, and combinations of all of the above with no luck.

There’s also no way out of Zerekriss I can see if you don’t have any hearths or teleports ready to go, so hopefully you’ve got a lot of those if you get stuck here.

Ticket submitted already before finding this thread, we’ll see if it goes anywhere.

same thing is happening to me. lfr popped while i was flying and all sorts of buggy stuff happened then it finally let me in. Cant fly with her now.

Also happening with me after doing a BG. Unable to interact with Xandria at all. Have tried relogging, exiting and relaunching, disabling addons, resetting interface, hearthing and rezoning. Nothing works, just cannot interact with Xandria at all. Unable to continue the quest.

Got the generic response to my quest issue ticket back overnight, replied to get it manually reviewed and pasted a link to this thread in there.

Still bugged, still stuck, ticket now says 13 days till a reply…

how do i get back up to the tower to re-accept the quest? I see no npc, nothing.

You should be able to talk to Xandria next to the Spider’s Watch flight path, but if you’re bugged too you just get stuck inside the necropolis once she flies you up there because she won’t fly you out.


I’m also having the same issue. A BG came up, did the BG, came back and the NPC Xandria is un-interactable. I’ve abandoned, retaken the quest and nope… I opened a ticket last night and got the same generic “there’s nothing we can do” response. Hopefully they fix this in a patch or something. Can we not progress in the campaign without this quest?

Yep, we’re stuck for good unless they fix it, been checking and checking. I’d try and call them, but that’s obviously not going to work.

So i found my way back up, go back to spider’s flight point and she will take you up. Though, once in the platform xandria is ignoring me like everyone else.
ticket got me a generic response…i replied and fingers crossed.

I am having the same issue. I found my way back up but I can’t interact with her. I even tried using interact keybind and command.