Cannot complete quest Fight and Flight (after hotfix)

Alright not sure if they just fixed it or I got lucky, but IF you messed up the quest due to BG or whatever, you CAN get to the necropolis but Xandria WON’T bring you back down, drop the quest, regrab it from Draka, hearth out, run back to flight path where Xandria is, fly back up and she should be able to be interacted with now. Hope this helps!

Still broken tried Aritoths method still not working

1 Like

Tried what Aritoth suggested. It didn’t work for me.

1 Like

Same issue. I tried Aritoth’s suggestion and had no luck as well… I also submitted a bug report with a link to this thread.

bonjour moi la quete apparait encore dans le netropole dans Maladruxx et je ne suis pas capable de me rendre dans le necropole aie-je une facon de la reaccepter la quete dans le necropole ou pas??? il y a tu un portal pour cela ou pas??? quest qui en ai??? dans combien de temps ce bug sera corriger.!? quelqun peut maider svp. Jai eu un summon pour un bgs et lorsque je suis revenu xandrial netant pas la jai abandonner la quete et jai pas pu rien faire. Je vois que le bug a ete reporter mais rien de la comment je fais pour la continuer.

tu pourrais tu maider de mon coté sur wow???

Got a reply to my ticket…erroneously stating my issue was with raid lockouts. Reopening again…

It’d be great if this could get fixed before the next reset.

Oh, just for thoroughness, I tried all the stuff Aritoth suggested when it started to no success.

Sent a tweet at Blizzard CS, they have no other lines of communication. Guess we’re all stuck with no covenant progress for the foreseeable future.

Y’all need to walk back to Spiders Watch, Fly Back up To Zerekriss, then use Xandria again. The same flow you followed the first time.

1 Like

Did that, multiple times. With logouts and hearthing and dropping the quest in between. It doesn’t work. Xandria will still fly you up to Zerekriss, but on accepting the quest, she’s non-interactive inside Zerekriss.

2 Likes

Same not working at all.

I don’t know if they pushed a hotfix or not, but as of logging on tonight, dropping the quest, and flying back out there again, it appears to now be working for me. Xandria is interactive in Zerekriss after starting Fight and Flight this time.

je vais aller verifier de mon coté. vla 2 jours jai faite le debut de la quete avec xandrial et lorsquelle ma transporter a lexterieur de la necropole jai eu un summon pour un bgs et lorsque je suis resorti de mon bgs bien elle netais plus la et depuis ce temps elle nest pas interactif du tout. la je men retourne et je vais essayer.

Seems fixed for my character. Xandria now flies me down.

1 Like

it finally worked for me. Drop the quest and retake it from draka, Hearthstone out of the place then go back to Xandria from the flight path where it take you up. If this doesn’t work for you, hearthstone out and wait for a day. After reset, go back Xandria again by the flight path and it should work now.

1 Like

I abandonded quest in bastion, then flew to spider’s watch. xandria flew me to platform. then got quest from brakka, then xandria did interact. seems to be working again.

2 Likes

So it would seem that a few of us did this with kyrians, switched to necro, and now we are bugged. Think another ticket would expedite the fix?

My post for similar bug for Necrolords.

Here’s how you fix the bug. After Xandria fly you to the area and she doesn’t spawn, leave the area but don’t abandon the quest! Call it a day and wait for the next day, fly over using flight path and run towards where Xandria supposed to be at and WALLAH! She’ll be there. You’re welcome.