Can No Longer Access Guild Bank on Welcome Back Weekend Account

ETA: Bank access is back for me as of 7pm for both accounts. Thanks!

Hi, I randomly lost guild bank access on my other account, which is free to play this weekend via Welcome Back Weekend.

I was able to able to use the guild bank just fine earlier today. The last time I tried to deposit something, I received a “you don’t have permission to do that” error. This is a “personal” guild (i.e., I’m the GM), so no settings were changed on my end :thinking:

5 Likes

Yup. Having the same issue. I’m the GM of my own personal guild where all my gold are stored and stuff. Can’t access any of my own inventory. Ridiculous.

3 Likes

Someone else in GD just said the same, but apparently not on a free-weekend account.

YIkes…

Free is not free. False advertising there.

Not going to pay money to check out my own inventory/bank.

With all that gold in my bank, I could be buying a a subscription with it. But nope. Guess they screwed up again.

1 Like

I am having the same issue. None of my characters can access the Guild Bank. Anyone???

1 Like

Same here, also not on a “Free Weekend” account. Was working fine earlier today, switched toons, now it works on no one. Verified permissions, reset UI, nothing seems to fix it.

1 Like

I’m having the same problems. On two different old guilds on different servers from a recovered account for the free weekend. But I had my new account and old accounts merged and the new account can not access the old guild bank either.

1 Like

Anyone put in a ticket?

Same thing here - I have a second account and I cannot access the guild bank on him any more even though all afternoon I could with no issues. I thought it was an addon problem but after disabling them all I realized it wasn’t that.

I cannot even promote that char to guild master - the option isn’t there. So this definitely sounds like a bug. I submitted a ticket about 15 minutes ago.

1 Like

I submitted a ticket about a half hour ago.

1 Like

Have same problem on a regular PAID account. Dont have access to personal guild banks or any guild banks for that matter. was fine last night.

2 Likes

I came here looking to see if anyone else was having this issue. Looks like I have plenty of company.

None of my characters can access my guild banks. Not the guild masters, not the officers, nor any of the others.

1 Like

Same issue. I tried on paid and free accounts. All toons and all servers tell me, do not have permission to even open up the guild bank.

Mine just got fixed. Tried to access the guild bank for the 97th time in the last few hours and it finally worked. So it looks like Blizz did something about it.

2 Likes

I can’t access the guild bank with the guild im in with any of my toons and i dont know why anybody still having this problem and if its on blizzards end what should i tell them ?

I’ve a newly found guild and only 1 member has access to it (GM). Other toons, can’t access and their permission levels were all ranked as member. Suggestions?