[Bug][TBC] Stuck in Druid forms

Multiple people are reporting that they are getting stuck in cat form with the wrong bar (has caster form bar). Attempting to use spells doesn’t remove form like it normally would. Seems to correct itself after 3-5 seconds.

I’ve had it happen and be unable to even use a /cancelform macro to leave form


Can confirm, here is how I can readily reproduce:

  1. Shift to cat form
  2. Wait for 1 tick of energy
  3. Shift to cat
  4. Try to shift to cat immediately

Previously, you were able to shift forms with abandon. Now when I reach step 4 I get the error message “you are in shapeshift form” and I am “locked” in form for about a total of 3 seconds after shifting. I am not on global cooldown, but I cannot /cancelform and I cannot shift forms.


+1 to this. It is also repeatable in any form not just cat form. You can similarly shift to bear form, wait for at least one server tick, power shift, then are stuck in form for approx. three seconds after.

Same bug happens with travel form and flight form (on the ground).

Of note this only happens when powershifting the same form. You will not get stuck in form if you go from cat to bear, for example, and can still immediately cancelform the second form.

Additional note is testing this repeatedly is causing my game to stop responding and crash.


Also seeing this happen when attempting to switch forms, i.e. going straight from cat to bear.


im losing arenas left and right getting stuck. this never happened before must be something in the patch


/cast [stance:1] !Dire Bear Form
/cast [stance:2] !Aquatic Form
/cast [stance:3] !Cat Form
/cast [stance:4] !Travel Form

can replicate problem with this powershifting macro which worked perfectly before today- go into travel form, wait a moment, then try spam powershifting and u’ll get locked up like Misscellany says


I’m having the same issues as above but I also got stuck in Travel Form while healing on Supremus last night. It lasted for most of the fight, I could not change into anything else, and ended up spamming /cancelform into the console about 20 times before it worked. So it took about 30 commands total before I released.

I also had to write old school Classic style /cancelform macros between pulls for Nature’s Swiftness, Healing Touch, and [@player] Healing Touch. /console autoUnshift 1 is broken and doesn’t work.

Not what I want to experience right before an outdoor raid, especially for someone looking to respec Feral for ZA.


Experienced this a few times yesterday both in arena and while raiding Black Temple. I thought my UI bugged but seeing this now it must have been this same issue. Was stuck in form and unable to shift out to human form or switch between forms…essentially just got fully locked into whatever form I was already in.


Can confirm, I am able to reproduce it consistently. First noticed it happening when I tried to swap from cat to bear to tank something and couldn’t get into bear form :frowning:


I also had this happen last night, when I would swap to bear from cat, none of my abilities would work, and then I would end up in caster form.


Had this happen in Hyjal last night.


Yup, noticed this all last night, and it trashed my DPS a few times.

I really, really, really hope this gets fixed.


There seems to be 3 different bugs identified (compiling some information from posts)

  1. If you powershift in a form, and stay in that form for an energy tick, the next powershift you will be stuck in form for 3 seconds
    ie: Cat → Energy Tick → Cat Shift → (cannot shift/leave form for 3 seconds)

  2. If you are in a form and cast a spell, it will not cancel your form (auto-unshift = 1 no longer works)
    ie: On supremus you run around in travel form, you cannot break the form with casting a spell. You also cannot leave the form using the shift buttons below unless you specifically click the travel form icon to cancel, or cancel the aura (right click buff or /cancelaura travel form).

  3. If you shift between forms you can get locked in a form with a caster bar, or be locked in with your bar and unable to switch between forms.
    ie: In the video below the player is stuck in cat and cannot switch to bear form. I believe you can unshift by canceling the aura (/cancelaura cat form) or clicking the catform icon - but this is not how it would function previously.

Please respond if you can think of other scenarios or work-arounds.

Update: It seems both /cancelform macros and /cast !cat form macros are failing, but /cancelaura works (it just isn’t GCD safe like /cast !cat form is).

Try using:

/cancelaura dire bear form
/cancelaura cat form
/cancelaura travel form
/use cat form


Hey! I’ve been using these macros forever, and don’t have this issue. When I tried using the default form spells from the spellbook, I was able to replicate the problem.

As a fix, try using these macros:

Cat form

#showtooltip cat form
/cancelform [stance:1/2/3/4/5/6]
/cast [nomod]cat form

Bear form

#showtooltip dire bear form
/cancelform [stance:1/2/3/4/5/6]
/cast [nomod]dire Bear Form

i get the same problem with these, tested with trying to shift every GCD +cast to cancel form after power shifting a few times. : /


Our tank is also having issues with this… Blizzard can we get a response and fix please?


This applies to just a generic /cancelform macro as well. Using the macro has about a 70/30 chance of actually cancelling my form and returning me to caster.

To clarify: Most of the time when I cancel form it does work as intended. But when it doesn’t work I do not get the “You are in shapeshift form” error that I get when using my powershift macro. Instead I just don’t cancelform as if I never pressed it.


cant 1v1 a mage rn. im literally sitting in roots like a warrior. getting shattered left and right. SOS


Game is fairly unplayable in PVP and some instances for PVE as feral right now with this bug.


Cut them some slack guys, it’s not like this is a 15 year old game that has already gone through this same content progression … ohhhh wait… nevermind!

1 Like