[Bug] Quest: Infiltrating the Castle

I uploaded this quest video during Classic Beta. Four comments (from different players) were posted within the past 2 days that this quest is bugged.

This was their response: Tyrion is actually there, but the complete quest button doesn’t appear, nor a question mark on top of his head. Therefore, players can’t turn in the quest to continue the questline.

In another issue, a player said the question mark was there, but he couldn’t turn in the quest.

It is unkown if layering changes implemented recently are at fault. Worth checking out.

A third comment in my video says: as the previous comment i have the same problem been sitting there for roughly about 40min and no question mark appears even tho it clearly showing on the map. any solutions ?


Same issue here


Same issue. Going on two days.


Also experiencing this issue. Came to see if someone posted about it on the forums after I submitted an in-game bug report and put in a ticket, so thanks.


this really needs to be fixed cause my server no one can do this questline cause someone failed the quest then never came back to redo it so no one else can do this quest.


Bugged for my lock as well, completed it on my priest a week ago. Gimme mah ring!


Same issue here


He’s there, the robot is there, but no matter how long I wait he doesn’t respond other than telling me to wait and not be seen. I tried dropping and picking up the quest again and no luck. I’ve been trying for several days and have waited up to 30 minutes at a time.


Hey I am having the same issue, checked in multiple times but the quest just isn’t popping for me.


same here, this quest is bugged

I was finally able to do the quest last night; it was about 12:00 am server time (Grobbulus). Arrived in the throne room and Tyrion gave the completion for the first step. I did have to wait in between the next stages of the quest for two other players to finish “the attack” but everything appeared to be working normally and things were respawning ar a tolerable speed.
I think what might have happened is that someone let the quest begin and then left without killing Marzon or Lord Lescobar, which locked Tyrion into the “quest in progress” state once those NPCs despawned without having been killed. I noticed a priest seemingly try to force this by initiating the quest “The Attack” and then logging out, but I killed Marzon and Lescobar for her so the quest reset normally after a few minutes’ wait.
I am not sure if there is a fix planned for this, but I think it would be advisable, as some players seem to think it’s funny to lock others out of the quest by exploiting this mechanic, leading to much frustration and wasted time.


I was finally able to finish mine yesterday too. The whole process was rolling along nicely at that point.

Big F if that’s what’s happening here. Hope the now 2 restarts have fixed it completely.
Luckily I got mine done in the wee hours of the morning. Also helped 2 others with it. All pretty smooth, though it’s a bit of a wait for things to go down.

1 Like

It is still bugged for me. ):

It’s working fine for me.

Its bugged on Smolderweb server. Cannot interact with him.

1 Like

I came here because I thought this was bugged for me too but after reading some helpful posts here I went back and waited for about 15 seconds. Then robot clanked up the hall and after Tyrion (GoT? lol) greeted it, I handed in the quest with no issues.

This is frustrating, you talk to 6 different people before you turn in this quest and there isn’t a way to complete it. Blizzard are you paying attention to this thread???

Bugged for me too!

Only thing I will point out is… it Seems to be for at Least level 31. However, I and another were able to Accept the Quest at levles 23 and 18 . Though, some Dipweeds might be buggin it on purpose, others, like myself, are proby starting it and getting Wiped. Think I’ll wait til lvl 30 and try again. @Blizzard, please adjust accordingly.