Bonus Objective: Tranquil Pools. Not completing

While working on my second character for the expansion I was doing the bonus objective in Ardenweald named: Tranquil Pools. Once hitting 100% of the bar, the objective greyed out and isn’t completing. It didn’t show another objective like some do for the “boss” or event of the objective.

Edit: I have tried logging out in the zone and logging back on and didn’t get the complete. People have had some success with this method.

10 Likes

I have had the same issue; hopefully I’ll get the experience retroactively

1 Like

You have to use the knife to cut open dead hydras to release Fairies from inside. But even after doing that and releasing over 50 and completing the objective it won’t complete for me either.

3 Likes

yeepppp just experienced the same thing. great job blizz. what do? haha

1 Like

Same thing with me, anyone figured it out?

2 Likes

Adding in that the same thing happened to me on my Mage. Got it up to 100%, grayed out, but no loot; it also still shows up on the map as if I need to do it.

Exiting the Tranquil Pools area and walking back in did not fix the issue.

I then logged out of the character while in the Tranquil Pools and logged back in. That triggered the reward.

Hope this helps!

47 Likes

This worked like a charm. Thanks! :slight_smile:

1 Like

Logging out in the bonus Obj area works :slight_smile:

1 Like

Sadly I have tried this myself when I first got the issue and still not getting it to complete.

Can confirm. Completing the bonus objective and cutting open hydras does not complete the bonus objective. Logging out and back in will complete the bonus objective. Small glitch. Frustrating as all heck but small.

2 Likes

Thank you for this! Worked for me as well.

Thanks, logging out and in again worked to complete the bonus objective for me too.

Worth noting that you -must- be in the area for the bonus objective when you relog. I was halfway across the zone when I found this post and tried it there and it didn’t work. I had to go back to the right area and then relog again.

Yep, this just happened to me as well.

I am also having no luck with the quest completion.

This worked :+1:t2:

Brilliant! This worked for me as well!

I too had to relog while in the bonus objective area in order for it to complete. Had a ticket with Blizz opened and they closed it with their typical generic response of disabling addons and checking Wowhead for information.

Thank you for this info!

1 Like

@Kejala thank you this worked. Go to pools, log out, log back in.

1 Like

A week later, this still happens. Logging out and back in did NOT fix it for me. RIP experience and 20 minutes of my time.

This helped thank you