Black Screen/Driver Crash

Computer Type: Desktop
GPU: AMD Radeon RX 7900 XT
CPU: AMD Ryzen 7 7800X3D - 8 Core
Motherboard: Gigabyte X670E Aorus Master
BIOS Version: F11
RAM: Teamgroup T-Force Delta DDR5 32GB (6000MHz)
PSU: Corsair RM1000X
Background Applications: World of Warcraft, Discord, Google Chrome, AMD Software Adrenaline Edition

I’ve been having an issue where my screen will freeze, for a few seconds, go black for a couple more seconds then go back to normal (in most cases, some cases I’ve had to turn off my computer otherwise it just stays frozen). I’ll then get a pop up box from AMD Software saying a Driver has stopped responding.

This mainly happens in WoW, sometimes it’s once every few days, sometimes numerous times in a day or consecutively. I’ve put over 100 hours in other games and never had the issue where WoW seems to have it at minimum every few hours.

I’ve updated drivers, adjusted graphics settings and nothing seems to change anything.
Anyone have a possible solution? Not trying to have this happen considering new seasons starts next week and I’ll be doing M+ and Raiding

What worked for me:
Switching to Dx11 solved the Driver Timeouts for me, DX 11 seems to be working now instead of giving a crash after a couple hours due to insufficient memory. Seems like these fixes don’t work for everyone though.


Following. I have the same graphics card but with a 5800x CPU.

Someone had previously said switching from dx12 to dx11 fixed it for them, gunna see how that works out

1 Like

It doesn’t for most: DX12 Doesn't Work In 10.2

I had the same problem with a card of that series (which I had purchased not long ago). I got fed up and returned it and went back to using an older card which has worked fine since then.

At that time people were using the latest drivers and when they went back to an earlier one, the problem seemed to resolve. There is some sort of conflict between the latest driver(s) and the game. I suggest a search through the Tech forum to find the driver numbers to try out.

Hey, I too have that odd issue as well. Been happening a bit more often as of late and I thought it was my 7900 XT messing up. And I have same spec as you do, OP except my CPU is Ryzen 9 7900X3D

I haven’t had an issue recently after switching to dx11, I’ll update later or tomorrow to confirm

1 Like

Did you switch it to dx11 in game or in command line? I heard that someone said something about command line but not sure.

1 Like

I was having this with my RX 7600.
I forced dx11 at command line by adding -d3d11 and haven’t had any issues since.

1 Like


I want to confirm we are looking into a known issue with AMD GPUs not launching crashing on startup or taking longer to launch(up to 3 minutes). Our team is on the road to getting this resolved soon!

I do want to clarify: if you are crashing on startup, try clearing the AMD shader cache following the steps Here. This may help stop the crashing, but the game will still take 3ish minutes to start, but you could still use DirectX12 once started. The primary workaround is launching with DirectX11. Be aware that DirectX11 may have its performance issues. You may need to lower the graphics quality settings lower than you normally are used to until this is fixed.

Thank you!

1 Like

Same issue for me, 7800XT, switching to DX11 did not resolve the issue for me, still getting a hard crash after some random amount of time with no idea what is causing it. No data on the crash in Windows reliability center or event log other than “windows did not shut down correctly” after the reboot, no crash logs from the game.

Have tried everting you can think of, up to and including a fresh install of windows, also switched from Win10 to Win11. All updates installed, all drivers up to date, reinstalled game, no overclocking, CPU and GPU temps are both very good, and system is stable in every game other than WoW & in benchmarks (to test for possible power issue). WoW was stable prior to the 10.2 launch. My settings don’t even max out my GPU/CPU when playing.

My partner’s system on the same CPU but a Nvidia GPU (3060Ti) has no issues.


I did it ingame, haven’t had an issue yet

1 Like

This issue started for me specifically with the 10.1.5 patch and after, 10.1 and before this issue didnt exist, i also use a 7900 xt. I have had to use Dx 11 for months now.

Its also not related to this issue, the game does not take longer to start and does not crash on start or hang. This issues arrives when DX 12 is enabled and you are just playing the game, it will randomly have a driver crash as some point during the day at no apparent point which you can fully anticipate. Sometimes it wont have a driver crash for multiple days and other times it will have a driver crash twice in the same day.’

This issue doesnt appear to ever occur even once when playing any other dx 12 title period. No amount of benchmarking can seem to reproduce this driver crash problem with dx 12. Patch 10.1.5 has felt like a culprit to me. Have tried the same driver version as used prior to that patch and every single driver version that has come out since. ALL of them result in the same frequent / infrequent driver crashes.


Zuvy, I worry you guys are only addressing the startup issue. There is a much deeper issue with AMD 7+ series GPUS with DX 12. The game occasionaly, and sometimes very often, will crash during gameplay. I noticed it most in Dungeons, or raid scenarios. It never happens in open world. Myself and other users have been reporting it all last season, but no one has ackowledged or addressed it.

Even right now, If I swap to DX 12, I get 50% of the fps that I get in DX 11. And Im running 7900 XTX, with 7800X3d cpu.

DX 11 seems to be very buggy right now as well.


I wanted to chime in on this topic since I’ve been having this issue recently. I have a 7900XTX but with an intel 13700k CPU. I just updated the GPU driver from AMD, version 23.11.1. Granted I had my game open but the game froze and upon a quick update from the blizz client, the game wouldn’t launch in the normal amount of time and I ended up restarting my PC just to have it take a while again.

On top of this issue, over the past few weeks my graphics driver has crashed in-game, only in retail WoW. There is only 1 instance I found a repeat offender and this is in the questchain A Call to Aid in Emerald Dream. Specifically when we’re in the cave attempting to cleanse the spirit in Shandris. It happens right after you talk to Lilian after she comes into the cave. Something in the sequence between Lilian and Shandris causes my driver to crash. This crash also happened today in my the Dawn of the Infinite’s m+ dungeon, with the trash packs right before the Manifested Timeways encounter. If I had to guess it’s something to do with the particles/dust effects.

I’m pretty sure it’s the same issue. I also share the sentiment that it’s 7+ series AMD. My much older PC that I just replaced never had a crashing issue on it’s 2080 Nvidia GPU.

Hopefully this gets some attention to get fixed, because I’d rather not have this issue mid pull in raids.

I’m going to try the D11 workaround now that I’ve found out about it.
EDIT: D11 makes the graphics feel much worse, but will continue to see if the crashing stops.

7900xtx here. Also having problem with DX12. I have had this once-a-day crash where it goes black screen (i can still move my cursor around) and then like “resets” the monitor and the game goes back to normal.

It doesn’t happen often and only takes away like 15 seconds of my time so i never reported it.
I also have to launch Classic WoW in DX11 for it to work currently. Please fix.

1 Like

AMD System here with 7900xtx

I am also having the black screen issue - it seems to even happen more often when im not doing combat-intensive tasks. For example, I could run 5 mythic dungeons in a row fine, but then I might plant a seed in the emerald dream and then get the crash

black screen, and about 5 seconds later I am back

this only happens in WoW

Edit: I wanted to add, this has been happening since 10.1.5 and no matter what driver cominbation i use, I cant solve it. DirectX11 works, so it seems strictly a DirectX12 issue.

1 Like

7900xt / 7700x, gpu driver crashes been occurring with DX 12 since 10.1.5 and after with every gpu driver version, but never prior to that patch. DX 11 is the only solution and its a terrible one to be forced to use only DX 11 on a high end gpu. Seems like something changed between 10.1 and 10.1.5 that started causing this driver crash problem.

1 Like

So switching to Directx11 seems to have fixed the crashing issue, but ever since I switched my WoW keeps crashing due to not enough memory, check my logs and WoW some how caps out my 32g of DDR5 ram, I have less addons than I had for my old PC

So fixed the driver crash and added a memory crash? idk

The memory leak issue is linked to dx 11 as stated by a blue post in a recent thread as well. Damned in both scenarios.

Play with dx 12 with new amd cards and get driver crashes, play with the solution which is dx 11 and get memory crashes…spectacular patches.