An End to the Killing - Anduin replaced by Turalyon

In attempting to clear the Ready for War achievement to unlock the Dark Iron dwarves, I’m stuck on one of the final quests: An End to the Killing. Anduin is not present in the throne room of Stormwind Keep. He has been replaced by High Exarch Turalyon.

I have reviewed older posts about this quest that suggest that it may be due to instancing interactions with other quest lines, but I don’t appear to have any of the quest lines mentioned. I believe I’ve completed On Whispered Winds/Shores of Fate/In Teldrassil’s Shadow.


(This is not a WoW Classic post, I’m playing as a level 50 Human Priest. Just updated my character for these forums, sorry for any confusion.)

I’m having the same issue, and it’s pissing me off. Trying to unlock Kul’Tiran allied race, but Turalyon took the throne the moment I did Shores of Fate.


Another poster experiencing the same issue: An End to the Killing - Anduin replaced by Turalyon - #2 by Tillia-mannoroth

I got a response from a GM claiming that this issue has been fixed, but I’m still seeing Turalyon on the throne, and Anduin is nowhere to be found. Anyone else to confirm if this has been resolved for you?

I checked just now on an alt that happened to be in Stormwind and Anduin was nowhere to be found, but that character doesn’t have any quests to turn in to him either. Yesterday when one of my characters needed to talk to him (to get started on BfA) he was in the room on the left as you’re walking up the hall towards the throne room (Petitioner’s Chamber).

Darn. For this quest and the other quest An Unwelcome Advisor linked above, there are quest markers that show he’s supposed to be on the throne, and the GM response mentioned the throne room directly. I double checked the other rooms just to be sure, but still no Anduin. :frowning:

For those who may have come across the solution of having your friends use party sync with you to change your phase: I can say this worked for me for the quest An Unwelcome Advisor, but not for the quest An End to the Killing. It was a bit hit and miss - this hack did not work on the first try, my friend did have to swap characters a couple of times to work.

So, An End to the Killing is still broken for me, and I am still forever stuck from unlocking the Dark Irons. :cry:

1 Like

So for me, I need to complete the intro Legion quest line to fix this. Specifically, I had to witness the teleport of Dalaran and obtain the Dalaran Hearthstone. Once that completed, Anduin then showed up in the throne room instead of High Exarch Turalyon. If the funeral procession is still then the throne room, completing the intro to Legion quest line should allow you to complete An End to the Killing.

On this character, I had already played through Legion. It is worth noting that I played through the war campaign on an alt, and everything worked fine - so maybe this is fixed now?

1 Like

this did it for me too. Legion then Dalaran teleport.