Failure to claim reward from event dungeon

In addition to a description of the bug you are reporting, please provide:

  • Device Type: Mobile
  • Device Model: Xiaomi Redmi Note 10 Pro
  • Device Operating System: Android 13
  • Warcraft Rumble App Version: 1.3.0


I can’t claim the reward from the event dungeon, it will always return an error after tapping the “Claim Reward!” button. The error message says: “Dungeon Reward Claim Failed - Something went wrong when claiming the dungeon reward.”

This happened when I never claimed the reward for a specific hero, and then switched it to another hero for claiming, w/c then results into the error stated above.

Hoping for this to be resolved soon.



Have you tried close the game completely before restarting the game, when you close the game it might still be in memory
there is a video " How to Close Running Apps on XIAOMI Redmi Note 10 Pro"

1 Like

Hi Karldrogo,

Yes I have tried that, but to no avail it always shows the error.
I have also tried signing in and out to see if it fixes it, but the error still occurs. I have also tried reinstalling the whole app itself, but to no avail the error still occurs.

It could be that my account data got corrupted regarding claiming the dungeon rewards.

1 Like

I’m having the exact same problem, if possible could i receive help too


I am having the same exact problem as well. Please help. Thank you!

Same exact problem! Anyone has a solution?

1 Like

Same problem here i cant even get the exp from the map or in pvp and i buy a special offer recently didnt received the tome exp …


Phew I thought I was alone about this. Can’t get quest exp. Daily progression, no dungeon completions, no campaign credit. Nothing. The only thing that works is buying units with my gold. Blizz we need you

1 Like

Also in the same boat. Been like it for the last 12ish hours. Cant claim any rewards, pvp rank not changing, quests not completing and unable to make progress on daily tomes, cant do dungeons nor progress on the map on either normal or heroic difficulties.

Samsung galaxy s22+
Version 1.5


The same issue on Android, after more than two weeks playing now I cannot collect any rewards, I have tried uninstalling, deleting data and cache but the problem persists

1 Like

Same issue on iOS. Very annoying and messed up that Blizzard don’t seem to do anything.

1 Like

Same here on both of my devices, android and iOS. Tried to clear app cache and reinstalled the game. So it seems to be account related.

Im only claim, daily ofers, yes its account related

Same experience here (no pun intended). Unfortunately completely game breaking as I cannot progress any further, being unable to collect any xp from dungeons or quests.

Samsung Galaxy S21 5G 256GB.

Yup, its most likely account related since clearing the game cache, uninstalling, and re-logging in wont fix it.

I have same problem.

Cannot upgrade mini deck in dungeon. Get error message.

1 Like

Weeks later and still unable to participate in Dungeons. Feelsbad

1 Like

Same problem here, sadge

Was able to fix this by equipping the same team I initially completed the dungeon on.

1 Like

Same issue for me. Error message 2.1.077414/77433