Warcraft III: Reforged Known Issues -- Version 1.32.9

Another ingame bug I noticed, the fire from the buildings in the fog will sometimes flicker, does it have something to do with vsync being on or anything like that? I play on all high but no performance issues so far

1 Like

I’m experiencing a black screen with a cursor and backround noise no idea how to fix please help


I couldn’t play the updated version of the game unless i uninstalled them and now i can’t get the updates anymore. I can play campaigns but only the characters have new graphics everything is the same as the old wc3.

There seems to be an issue with keyboard detection and the left mouse key.
I found a post on the blizzard forums explaining the issue, basically pressing the left key blocks keyboard input for a trigger. I found this out while trying to test a top-down shooter concept, unfortunately has failed due to the limitations created by this issue.

BlzTriggerRegisterPlayerKeyEvent and TriggerRegisterPlayerMouseEventBJ

When i put in window full screen the subitletle disappear.

Hey blizzard, I’m just curious regarding the custom campaign feature from the editor. How am i supposed to launch the custom campaign now? Usually I had to test it through launching WC3 finding the custom campaign and playing it through. But in reforged i can’t even find the option to play custom campaigns. Am I looking in the wrong place or how should I access the maps I’m trying to create?

I played a couple of games; here are mine so far

  • Units do not obey allied colors. E.g. teching, calling militia, impaling will cause them to flip to their OG assigned color.
  • Units make no sound when produced, unless when looking at the production building.
  • The ‘Victory’ screen at the end is offset to the bottom corner.
  • The game still shows “blizzard” has left the game, when a player has left.
  • The chat still overlaps with other option menus, such as in custom games.
  • I linked my classic account. As far as I can see, this does nothing (e.g. it does not provide any icons).
  • There does not seem to be any profile for any player?
  • Commands as /stats, /time do still not work
  • When loading is complete; the loading text keeps cycling. Making it unclear if the blue bar is incorrect of the text is not holded when done loading.
  • Switching to classic (booted from the classlic client) will open the classic replay folder.
  • It may occur units give no voice command when selected (had this with HU, peasants, priests, footman, am, but not with MK).
  • Completing a game caused my mouse to be unresponsive, even outside of the wc3 client
  • FPS is much lower. In classic settings I have 175 (pre reforged: 200). Reforged has 85 (in 1on1, I don’t want to imagine 4on4 or larger CGs)
  • When watching a replay; hotkeys do not work (e.g. f10 to open menu).
  • Changing some specific option menus will switch classic back to reforged. For example turning off game music.
  • Some unit sounds may sound occasional sound very loud; as if midly closer to the unit (visually) over-amplifies its sound.
  • In classic mode, the minimap is reforged design
  • Shallow waters terrain appears highly pixellated (in classic mode)
  • The color red (allied colors) appears more brownish than red (in classic mode)
  • Ghouls make a murloc sound when dying
  • Reported by friend: archers in classic mode have reforged sounds
  • Reported by friend: General chat is spit into multiple general chats (I assume, when the channel is full it puts new people in a subsequent general chat, as in classic). However, it is not visible in which channel you truely are.
  • There is a very minor delay between hitting enter and the display of the message
  • Dying spirit wolves make a blood splash sound
  • Some maps (e.g. twisted meadows) have some bird critters flying across the screen at almost lightspeed.
  • Whispering a friend has 2 - 7 seconds delay.
  • As a more general rule of thumb, many units in classic settings seem to have audio from reforged.
  • General chat channel ignores profanity chat filter. I have it off, yet the correct spelling of foock shows as @#$!.
  • In general chat, the blue scroll bar does never hit the bottom, even when you are up to speed in chat.
  • General chat often does not automatically move along with new messages and has to be scrolled manually
  • Opening a specific option in the option menu may expand into a list, causing a scroll bar on the right side to suddently appear.
  • The AT overview before a game disappears when everyone selected a race / is ready. Make it hard to see who is in that team with which race.

I can’t change the graphics to reforged so i buyed nothing for 30$ ?


If your get a campaign error, stating: “Defeat”, after trying to play prologue campaign. Try to disable the Language Profanity setting in menu. This worked well for me, but very few have this information, so I’m posting it here

1 Like

I can’t seem to log in? It keeps giving me the same error. “There was an error handling the request”. I have classic WC3 TFT and clicked to update but now it’s not even working at all?


I don’t know about other custom games but YouTD have been completely destroyed, some of the feautures works like before but the important parts isn’t working. You can upgrade towers regardless of the element level, lost all my levels on my charachter. And most importantly oils doesn’t work…

When I’m in Campaign I have 2 issues.

  1. At the end of a mission the game freezes and I have to quit.
  2. In one of the missions the dig of war completely covered the map. I couldn’t see my own troops and base. I could how’ve see the opposition.

In Custom Games the Human AI (normal) wont upgrade the Town Hall so it only hoards tons of Ressources and uses only Tech 1 Building and Units.

My issues founded during using the original version of Warcraft3 reforged on mac.
-At the middle of the versus game, structures and units are seen as shadows and never come back.
-navigate in mini-map is impossible.
-when playing the campaign the game gets freeze and not able even to go back to desktop with command + shift.
-My version of W3 TFT has been deleted and now I cannot even play the old version.

This is really disgusting to know that developers are not testing correctly on Mac version, they even play this game once during testing, or finish a complete versus game.
Please do correct QA for mac version.

Note: Do not download this version, will screw up your TFT version.


This game is garbage. It wont even let me start it. Stuck in the launcher. I want my money back. This game is a piece of crap and I have not even started playing it yet!
Blizzard continues to show how incompetent that it is. Way to go! You guys look like idiots once again!


nice blizzard, game is trash , give my money back and bring back classic


Subtitles not being displayed in-game cutscenes via Windowed Fullscreen (21:9/3440 x 1440P resolution).


My biggest issue is my original version is deleted.

Closed bets wasnt playable, so far my experience with launch is the same.

Now i cant play any warcraft because they got greedy as deleted out original wcft downloads in an effort to force us to play this game and or use the platform they want.

Shame on you blizzard, or whatever you call yourself.


Mind fixing “stuck in classic mode” as well?

tried pref text file, command parameters, drivers are of effing-course up to date, and nothing, NOTHING works!!

1 Like

I am so freaking pissed.

They deleted my original wc3 and tft.

Reforged is not even starting or giving me any message, what is wrong.

Its like D3 over and over again.

Blizzard, fix this ASAP or we all want our money back!