Mac: unable to launch game after upgrade to 1.31.0


#1

After upgrading to 1.31.0, I receive the following error when trying to launch the game:

Warcraft III Error: Unable to initialize graphics. Please ensure your operating system and display drivers are up to date.

As I understand it, driver updates would be provided by Apple in OSX updates through the App Store. I don’t see any available driver updates for my card. Prior to the 1.31.0 upgrade, the game ran perfectly for me.

System Information:

  • Machine: iMac (21.5-inch, Mid 2011)
  • OS: macOS High Sierra (10.13.6)
  • Processor: 2.7 GHz Intel Core i5
  • Graphics: AMD Radeon HD 6770M 512MB

Troubleshooting Done:

  • I was initially on 10.11 (El Capitan) when I received this message. I upgraded to 10.12 (Sierra), tried launching the game and got the same error, and then upgraded to 10.13 (High Sierra) and I’m getting the same error. I’m unable to upgrade to Mojave on this machine (not eligible).
  • Tried clicking ‘Repair’ and then re-launching.
  • Tried uninstalling Warcraft III and re-installing
  • Tried uninstalling Battle.Net launcher and re-installing
  • Tried restarting my machine

I saw in the 1.31.0 patch notes that 32 bit support was dropped for Mac, but I don’t believe this should affect me as my processor (core i5) should support 64-bit.


War3 doesnt work anymore on mac after update
#2

I have the same machine but with a 2.8 GHz i7 and high sierra. Same problem.


#3

macOS kills 32bit support so Blizzard had to push WC3 to 64bit and thats not as easy as you may think. Maybe there will be a hotfix soon but don’t count for that. Apples decision to kill 32bit on their OS is… well… pretty stupid and as an costumer I would be pissed of them. You guys wont be able to play older games anymore


#4

Same here with a 2.5 Ghz i5 and Mojave OS. My system is up to date and supports 64bit as well as metal. It also worked fine one single time. Couldn’t figure out why.


#5

Same issue here. Whenever I load into a custom game, I would crash immediately. RIP all MAC USERS XDD


#6

I can launch but can’t load any custom game. This patch broke wc3 on Mac for me.


#7

Same issue here.
Hope 1.31.1 will fix this issue on Mac.


#8

Edit: cant reply to this thread anymore for some reason, but they just messaged me again and said our macs are too old to run wc3 anymore because it only works with Mojave

I for one am PISSED this is the dumbest thing Ive ever seen its a damn game from 2003, why patch it like this just leave it alone and bring on reforged when you ready…

Well done blizzard just lost another player, not buying a new mac for wc3 lol


#9

Same issue here.
10.12.6


#10

same issue, 2011 macbook, i7, 10.13.6