StarEdit Deprecation in Patch 1.23.0

Thank you so much!!!

Good move. I do have to agreed with everyone. Or just add both editors and let people pick.

Go to StormcastFortress - Scmdraft

go to download list

Download the latest version - top of the list. Simple as that

I still have that issue

From your original post I assume you are talking about Galaxy Edit (SC2) and not StarEdit. Assuming that’s correct, you’ll need to post in the SC2 forum, not this one.

scm draft comes with some annoying assanus feature that wont allow me to edit unit stats on a custom map im making. I edit in all the stats, save it, load the map up and it has reset the stats. i.e lurker does 1 damage. if i reload the map up, the stats are totally reset to what they were originally.

Anyone have a clue how to fix this?

I just tried that and cannot reproduce that. (Changed comsat stats, saved + closed the map, closed the editor, loaded the editor, loaded the map, stats are still the edited ones.)

Note: Changed stats only apply in game for use map settings.

Can you post a step by step guide what you are doing?

I changed a crap ton of stats most of which took and worked: i.e i changed the health and damage of dragoons, the cost and build time of ghosts, hydra upgrade costs and so on. All of them worked and remained. Until I loaded it up a few days ago with the latest patch, I changed lurker health, lurker aspect cost, damage and armour. The health works and remains regardless, but damage always falls to 1, lurker aspects cost also can not be changed. I am hosting in use map settings!

Havent even added triggers to the map or anything.

Hmmm - try saving the map as SCX (via save as, or by placing brood war units) to force it to save as brood war compatible. I suspect it is saving it as SC 1.00 which means the game does not load brood war unit stats.

Let me know if that helps, then I will add logic that will prevent switching to 1.00 if brood war units have custom stats.

Yep that was exactly right. Thanks for the help!

edit: actually i have a question; its possible to save triggers and then load them up on other maps. Is it possible to do the same for unit stats on scm draft?

Dear Matt, I agree and I join as the request of others in that the classic editor is not retired. On the other hand I am very happy that they have considered it in publishing it again for us to be able to use it since both yó and for other fans it is much easier to use the staredit than the scmdraft2 for a usability issue. I hope the staredit comes in the next update as soon as possible for all of us who ask for it back in all available game languages. Thanks for listening

I purchased the upgraded Starcraft.
It included a map editor.
For some reason Blizzard took it away from me.
An item I had paid for.
At the very least I would like my money refunded.
Ideally a class action suit would be appropriate.

You have been given an alternative:

public staredit download

scmdraft 2 alternative starcraft map editor


I agree. If you have to replace staredit then bundling it is the way to go.

Holy $%&# I didn’t even know there WAS another SC1 editor!

(I don’t know where to post this topic so forgive me if my issues is better dealt with somewhere else)

I have downloaded the ScmDraft 2 installer EXE file and it installed perfectly but It will not run…
It opens the main menu but when I click the launch button (having changed no settings) it shows an error telling me to run it with the -console option.
When I run it with the -console option the error says it can’t load the cmdicons.grp fiile.
I googled this issue but cant find anything, I went to the stormcoast-fortress net homepage and poured my heart and soul into figuring out what is going on.
I even tried to go to the posted forum but couldn’t get anywhere.
PLEASE: If anyone has a clue how I can get ahold of the dev’s this would be realy great I have a screen shot of the problem… I hope it helps.

(sorry I dont know how to attach a photo to this post, and apparently I cant even attach a link to my google drive)
If you want an image of the issue just email me at steevxx at gmail

Scrolling a bit further down on the main forum would have revealed a bug report of the same error, which includes a response from SI. ScmDraft 2 doesn't open anymore

Ok, I used that and got the editor to work but the editor still complains about that missing cmd.grp file… i dont understand the problem with that missing file, but hey at least the thing finally works! THANKS!

Sorry about that, that was the quick 5 minute fix since I didn’t have much time, so it just tries to load it twice, and doesn’t prevent the error message if it fails the first time. A proper fix will be added soon™

1 Like

Hi, I’m fata and the leader of Korean map makers community.
Our community reported about lot of illegal advertisement game rooms which are full of spam site and URL. They disturb finding right game in game list.
It is not only single game but also lots of games. You can see spam games in below image link : https@://
(You have to remove @)
Please kick them all. Thank you.