SC remastered crashes at startup new Mac BigSur M1

Hi Blizzard support

I just purchased a new Macbook pro with the M1 (8gb ram). I used the apple migration tool, to move apps and data from my old intel macbook pro to the new M1 macbook pro.

Unfortunately SC Remastered crashes when I try to start the application. Some more information.

  • Big Sur is up to date 11.0.1
  • I have uninstalled SC remastered and reinstalled it.
  • Battle.net updated to latest version 1.29.0
  • Starcraft at latest patch 1.23.6
  • I am able to run SC2.
  • Rosetta is installed.

Thanks, any assistance would be appreciated.

KT

25 Likes

Hello,

I have the same MacBook Pro; I also experience a crash as soon as I attempt to launch SC remastered.

8 Likes

Same problem here on MacBook Air with M1 chip. Starcraft II works fine but not Starcraft Remastered.

7 Likes

11-28-2020 at 2:07 PM - PST

I’m NOT completely sure IF what I’m about to state makes complete sense; BUT:

As of Mojave, 10.14.0, OpenCL AND OpenGL WERE Deprecated. These continued in Deprecation Status in Catalina. I EXPECT that as of Big Sur 11.0.1 that NOT ONLY are these Deprecated BUT ALSO have been removed from Big Sur.

This means that as of 11.0.1, ANYTHING that requires OpenCL OR OpenGL WILL NO LONGER FUNCTION in Big Sur. Since, as of my last check, StarCraft:Remastered HEAVILY DEPENDS ON, (IF NOT REQUIRES), OpenGL to function that StarCraft:Remastered WILL NO LONGER FUNCTION under Big Sur.

Blizzard ‘MAY’ be working on a remedy via Metal Support, BUT, they ‘MAY NOT’. NO news on this has even been posted by ANY Blue Poster to clarify the situation. BUT, in their defense, Big Sur is possibly too new of a development by Apple for Blizzard to have an immediate solution, IF any solution at all.

Let’s think positively, and continue hope that Blizzard will remedy the situation and get SC:R working under Big Sur.

TimeLord04

[EDIT:]

Also, as Blizzard has a tendency to Deprecate OS Support to the LATEST 3 MacOS Systems for running SC:R; there’s POSSIBLY good news for those STILL running High Sierra… That is, since the LATEST 3 MacOS Systems that remain utilizing OpenGL ARE High Sierra, Mojave, AND Catalina, IT IS QUITE POSSIBLE that High Sierra WILL NOT be Deprecated by Blizzard ANY TIME SOON.

TimeLord04

[EDIT 2:]

Found this early June - 2018 article:

https://venturebeat.com/2018/06/06/apple-defends-end-of-opengl-as-mac-game-developers-threaten-to-leave/

TimeLord04

Hi I think its more than just BigSur and support of Open GL. Before I purchased my new MacBook Pro I upgraded my old MacBook Pro to BigSur and tested apps including SC:R. SC:R functioned ok under Big Sur using intel chips. It could be a bug in the Rosetta 2 (the Apple Intel to ARM translation library) added to Big Sur for the M1. We may have to wait for Apple to patch BigSur and fix the Rosetta 2 issue for SC:R to work again. I cannot be sure. Only Blizzard developers would be able to confirm this.

2 Likes

11-29-2020 at 3:37 PM - PST

@KTitanium,

Thanks for that update. I’m pleased to learn that Big Sur on Intel Macs still allows SC:R to run. Perhaps you are right about the Rosetta 2 Layer being an issue on the M1’s.

Let’s wait for a Blue to come by and clarify more.

TimeLord04

[EDIT:]

btw, I’m on Mojave on my Hackintosh and on my cMP 5,1. I plan to stay on Mojave for the foreseeable future.

I DON’T like that Catalina ‘carves’ up the Storage Drive, (HDD or SSD), into two Logical Partitions. I DON’T like Big Sur’s ‘Snapshot’ implementation, either. My Hackintosh WILL accept Big Sur, but I’m just NOT ready to make that jump.

I wish all the M1 Users the best of luck, and hope that Blizzard finds a remedy soon.

TimeLord04

3 Likes

I have the same issue. Blizzard CS closed my ticket blaming the external SSD I keep games on. It worked fine on my Intel Mac mini that way, though, even in Big Sur. This is an M1 issue and they seem to be ignoring it.

FWIW I did move the game onto the built-in storage and it didn’t change anything.

1 Like

Thanks for adding to the conversation. Did you anyone receive a detailed error log? I had something like this in it.

Thread 1:: com.apple.rosetta.exceptionserver

How do we get this to Blizzard? I am not aware of how to raise support tickets with Blizzard.

KT

1 Like

Yes, I reopened a ticket last night. I just copied/pasted the text out of the exception window into TextEdit and saved as unformatted text. They also want you to go to System Information and save the detailed report. I did both of those and then filed a report here: https://us.battle.net/support/en/article/15043

Like I said they saw “oh external drive? not my problem” and just closed it the first time. I then moved the game to the root /Applications folder (actually uninstalled/reinstalled, not just copy) and got the same result. I opened another ticket last night.

We need to flood them with these things from different accounts to get them to take it seriously.

I have a 2018 Mac mini with a Core i5 processor, and it can run the game okay, although not great, because Intel UHD graphics sucks. I was expecting a boost in performance even though it’s an x86 app just because of the better GPU. Diablo 3 runs really well at 1080p on the M1 Mac mini and it’s x86 only. WoW has been upgraded to a universal app and it runs amazingly well. SC2 has a little stutter to it, but SCR is the only Blizz game that crashes out of the gate.

Same is true for Hades, and I’m trying to draw Supergiant’s attention to that one.

Now the only game that will not run on my Mac mini is StarCraft Remastered. Supergiant fixed Hades with its post-launch patch.

3 Likes

The link provided does not show me anything. I tried to also create a ticket but it keeps on directing me to these forums.

Out of interest, I tried the PTR (Public Test Relm) on my M1 as there was mention of Metal support for Macs in the about post. Unfortunately, it crashes as well. No exception report though.

Hey everyone,

Thank you for the reports on this issue so far, and we appreciate all of the information that has been shared. Just wanted to chime in here and confirm that our Starcraft team is aware that the game is crashing on launch for M1 Macs.

They are working on getting the bug resolved as quickly as possible, but I’m afraid we do not have an ETA to share.

If we have any updates we’ll make sure to post in this thread. Thanks!

16 Likes

I am also having this issue on M1 mac, hopefully it works soon

1 Like

Same issue on my Mac M1

1 Like

Updated to Big Sur 11.1 today. SC:R still crashes unfortunately.

1 Like

Same issue for me on M1 Mac Mini. I also tried emulation but that also failed because I don’t have the installation files. Anyone know where I can download the .exe file directly?

Chiming in as well. Updated to Big Sur 11.1 and SC:R is still refusing to launch.

Hopefully the Starcraft Team can come up with a patch so that we can enjoy some Broodwar on these new Macs.

2 Likes

Any news, on fixing the problem?

2 Likes

any updates just bought the game and not working on my new mac.

2 Likes

I just got the new M1 Mac mini and it can’t run Starcraft at all

2 Likes