Replays created prior to 1.23 are not played back correctly

Hi all,

Since the most recent update ( replays saved prior to 1.23 are no longer working correctly. In all the older replays I’ve tried viewing, human players essentially stop doing anything after a few minutes into the game. After a few minutes, it seems that only existing units have their actions recorded by the replay; any new units just sit in place. The game then plays out completely differently than from what really happened.

This isn’t necessarily a new bug - I’ve seen this happen before to random replays saved in older SC versions, but as of this patch it seems ALL older replays are affected. There’s a Liquipedia article that basically describes the behavior but this site is not letting me post links. Has anyone else seen this?


It’s been several months since this post was made and I’m still having this same issue. It’s frustrating because I enjoy sharing and rewatching a lot of my replays.

1 Like

Do you have a replay you could share so that we can investigate?

I have several. How would I share it with you?

Hey there CrypticMoth,

If the file is smaller enough you can email it to us at - Keep in mind we do not send replies through this inbox so please post here after the replays are submitted.

If the file is too big for email, it might be best to utilize a screen recording software like AMD ReLive or Nvidia Share to record the problem and upload it to YouTube or similar service. Example youtube(dot)com/abc123

And if you do submit a broken replay, could you please let us know at which point in time you believe it breaks? i.e. a description of what actually happened vs what the replays shows? That would really help to narrow the scope of the investigation.

Apologies for the delayed response.
I’ll go through my replays and find one that’s not overly long to avoid file size issues. I’ll try and get it to you today if I can, and I’ll post here again when I do.

I just sent one titled: “2v2 zerg war”. It’s me and 3 computer players, one is my ally(orange player) and I’m the white player while the other 2 players are the other team. This one is good because it’s quite short and the issues are easy for me to point out.
I wipe out the purple player a few minutes in by building sunken colonies in his base and proceed to build a new base where his was. I distinctly remember having fights over the base with the other computer before I overwhelmed him.
When watching the replay before version 1.23, it would play correctly.

Here are the actual problems:
Around 8:00 or so, my units stop doing anything and my buildings are no longer producing anything as if I am not issuing commands, which I know isn’t what happened. This is made pretty evident when shortly after this, the teal player sends a group of Hydralisks to attack my new base. In the real game, I had produced units of my own to back up my sunken colonies(I believe I had just made some Zerglings) and made more buildings. What happens instead in the replay though is basically the Hydralisks coming in and having a brief skirmish with the sunken colonies before wiping out the base.
Later the match just ends without actually being finished. I know for a fact that I finished that match and took out the other computer player, but this isn’t shown in the replay. The length of the replay is correct though, just not what actually happens in it. Pretty much all of my replays, if not all of them have the same problems as this one.

The last post about me sending a broken replay in was a little more than two weeks ago. Has any progress been made? Did you receive the replay that I sent?

Yep, we’ve received the replay - thanks for that. However, the issue has not been investigated yet.

When was this replay created?

Hi there, just bumping this thread as I noticed a similar issue with one of my replays from last December. If it would help to have another example I can send it along with any other information (creation date/patch) requested.
Edit: I’m actually going to disagree with the thread name here, I played a game yesterday and it had the same bug occur so it’s broken for replays made on current patch too. The “break point” of the replay with what actually happened seems to come earlier based on the number of players/units, it was totally stable in a 10 min 1v1 vs AI but failed instantly 1v7 vs AI.


I’v experienced some really weird bugs with replays as well. Yesterday I was playing some really old replays (recorded before 1.16) with my friend. When I hosted a replay, it worked fine. However, after the first replay, my friend hosted one while I was browsing my replay folder in game (via create game menu). After he hosted the replay, I exited the map/replay browser and create game menu via cancel buttons. I joined my friend’s game and we started playing the replay. Everything was just wrong with that replay, map was incorrect and it even had wrong players in it. Terrain was glitched and players in the replay didn’t do much (just moved the workers around a bit).

I belive that the game somehow loaded the map and players from the replay that I had previously selected in the map/replay browser. When I joined my friends replay, it somehow mixed my friend’s replay and my replay together. My friend reported that he didn’t experience this weird bug like I did so it was entirely just on my side.

I took some screenshots:
Terrain is most likely glitched, because the map I had selected was on different tileset.

It was created sometime in 2018. Do you need the exact date?

Just in case it helps, the exact date that I saved that replay was July 9th 2018.

when remastered came out any old replay was watchable but some newer replays are broken lol

Has any progress been made on the issue?

This issue is still present and we’re kind of being left in the dark on this. It would be nice to get an update on the situation since you said that you did receive the replay that I sent.

[Edited by Blizzard] This thread has been inactive for some time. Please be mindful of resurrecting older threads. A new or more recent thread can be created to continue the discussion. Locking this thread.