Patch 1.23.5 Notes

the last patch sucks!!!
I was happy playing with out any problems!!! Why now I need a new graphic driver to play the old starcraft Brood war!! that don’t make sense!


tell me why a game from 98 needs to be patched still? some of us just want the old broodwar, no hd effects, first set of patches you guys sent ruined online play with lag, now you part cheeks even further and not let me play a 20 something year old game??? BOOOOOOOOOOO


MY Intel® HD Graphics driver is the latest, but starcraft tell me is old. It dosen´t run, please help.

hi, it show upgrade to but I cannot upgrade.
please show me the step to upgrade. I search the patch but no patch is downloadable.
pleas help. I want to play

dejen jugar … mi computadora es nueva…xq tantos parches…si asi como era antes esta muy bien, blizzar…

We’ve just released Hotfix Patch 1.23.5 which includes the following change:

  • Increased soft support for older Intel drivers

keep up the good work devs.

1 Like

has there been any progress on hotfix we may get to fix the stale/old games on the lists? the amount of stale games on there now is in the dozens. There are so many, and they have been there for so long, that it actually take significant effort to find a real game.

also, there was always a timestamp on games (years and years ago), and that went away with remastered. Can/will that ever come back? even if it isn’t a timestamp of when the game was created (everyone has different timezones), maybe it can say how long that game has been listed for?

1 Like

Still no support for Mac. Game continues to crash since the 1.23.5 patch has been released. The computer will freeze and require a hard shut down. Please fix.

8-6-2020 at 11:11 AM - PDT

Depends on the Mac, I guess.

Still NO Issues on my Hackintosh, all working as it should.

Profile: iMac 18,3 - 5K Retina 27" - Mid 2017
High Sierra 10.13.6, (17G14019) w/ NVIDIA Web Driver 387.

i7 7700K @ 4.2GHz
32GB Corsair Vengeance LPX DDR4, (4x8GB Sticks), CL14 - 2400MHz RAM
Gigabyte GA-H270-HD3 MOBO
Samsung 860 Pro VNAND-SATA 1TB SSD - MacOS, APFS
Samsung 860 Pro VNAND-SATA 1TB SSD - Win 7 Pro x64, NVIDIA Driver 388.13 - (WHQL)
Western Digital Black SATA 2TB Drive - (HFS+) 1 Partition, 1TB for Time Machine; 1 Partition, 1TB for Blizzard Games

ASUS VE278 - 27" 1080p Monitor - HDMI to PNY NVIDIA GTX-970 4GB Card, Mac Flashed
[EDIT:] Integrated Intel HD-630 DISABLED in BIOS. - NO HEVC

Again, all working well here.


I have reported here twice. Still completely unplayable on 2018 iMac running 10.13.6 High Sierra.

3.8 GHZ Intel Core i5
8 GB 2400 MHZ DDR4
Radeon Pro 580 8192MB

I recently payed for remastered version and haven’t been able to play since purchasing, I honestly want my money back at this point.


We’ve just released a maintenance patch ( that includes a substantial in-game performance/FPS improvement for some older systems.



Thanks! Not sure if this takes care of some of the other errors that started popping up recently, when joining a friends game it says <Invalid Password or

Thanks so much for your hard work everyone! I notice the smoothness. Excellent work!

Now imagine if people were nice about it, possibly give the programmers a reason to want to keep coding the game lol

1 Like

Still seeing terrain flickering sadly :frowning:

Could you please reach out to with your system info ( so that we can try to recreate the problem you’re experiencing?

Sent an email, thanks for your help and all your hard work guys <3


do you mind if i send you an e-mail about the blurry graphics problem as well?

Perhaps whatever that causes the flickering issue might have something to do with blurry HD graphics.

upgrade from the broken included radeon driver to the current one served by AMD.